CVE-2021-28675

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An issue was discovered in Pillow before 8.2.0. PSDImagePlugin.PsdImageFile lacked a sanity check on the number of input layers relative to the size of the data block. This could lead to a DoS on Image.open prior to Image.load.

References

https://pillow.readthedocs.io/en/stable/releasenotes/8.2.0.html#cve-2021-28675-fix-dos-in-psdimageplugin

https://lists.fedoraproject.org/archives/list/[email protected]/message/MQHA5HAIBOYI3R6HDWCLAGFTIQP767FL/

https://security.gentoo.org/glsa/202107-33

Details

Source: MITRE

Published: 2021-06-02

Updated: 2021-09-14

Type: CWE-252

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.5

Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
153337EulerOS 2.0 SP2 : python-pillow (EulerOS-SA-2021-2432)NessusHuawei Local Security Checks
high
153055EulerOS 2.0 SP5 : python-pillow (EulerOS-SA-2021-2345)NessusHuawei Local Security Checks
high
152397EulerOS 2.0 SP8 : python-pillow (EulerOS-SA-2021-2314)NessusHuawei Local Security Checks
critical
152314EulerOS 2.0 SP9 : python-pillow (EulerOS-SA-2021-2253)NessusHuawei Local Security Checks
critical
152285EulerOS 2.0 SP9 : python-pillow (EulerOS-SA-2021-2279)NessusHuawei Local Security Checks
critical
151567EulerOS Virtualization 2.9.0 : python-pillow (EulerOS-SA-2021-2209)NessusHuawei Local Security Checks
critical
151547EulerOS Virtualization 2.9.1 : python-pillow (EulerOS-SA-2021-2187)NessusHuawei Local Security Checks
critical
151351EulerOS Virtualization for ARM 64 3.0.2.0 : python-pillow (EulerOS-SA-2021-2123)NessusHuawei Local Security Checks
high
149818Ubuntu 18.04 LTS / 20.04 LTS / 20.10 / 21.04 : Pillow vulnerabilities (USN-4963-1)NessusUbuntu Local Security Checks
critical
149464FreeBSD : Pillow -- multiple vulnerabilities (f947aa26-b2f9-11eb-a5f7-a0f3c100ae18)NessusFreeBSD Local Security Checks
critical