CVE-2021-28211

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A heap overflow in LzmaUefiDecompressGetInfo function in EDK II.

References

https://bugzilla.tianocore.org/show_bug.cgi?id=1816

Details

Source: MITRE

Published: 2021-06-11

Updated: 2021-06-22

Type: CWE-787

Risk Information

CVSS v2

Base Score: 4.6

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 3.9

Severity: MEDIUM

CVSS v3

Base Score: 6.7

Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 0.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:tianocore:edk2:202008:*:*:*:*:*:*:*

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
151364CentOS 8 : edk2 (CESA-2021:2591)NessusCentOS Local Security Checks
medium
151152Oracle Linux 8 : edk2 (ELSA-2021-2591)NessusOracle Linux Local Security Checks
medium
151139RHEL 8 : edk2 (RHSA-2021:2591)NessusRed Hat Local Security Checks
medium
151091SUSE SLES15 Security Update : ovmf (SUSE-SU-2021:2161-1)NessusSuSE Local Security Checks
medium
151088SUSE SLES12 Security Update : ovmf (SUSE-SU-2021:2117-1)NessusSuSE Local Security Checks
medium
149103Debian DLA-2645-1 : edk2 security updateNessusDebian Local Security Checks
high
148855Ubuntu 20.04 LTS / 20.10 : EDK II vulnerabilities (USN-4923-1)NessusUbuntu Local Security Checks
medium
148602EulerOS Virtualization 2.9.1 : edk2 (EulerOS-SA-2021-1736)NessusHuawei Local Security Checks
medium
148590EulerOS Virtualization 2.9.0 : edk2 (EulerOS-SA-2021-1764)NessusHuawei Local Security Checks
medium
148310openSUSE Security Update : ovmf (openSUSE-2021-495)NessusSuSE Local Security Checks
critical
148251SUSE SLES12 Security Update : ovmf (SUSE-SU-2021:0987-1)NessusSuSE Local Security Checks
critical
148227SUSE SLES15 Security Update : ovmf (SUSE-SU-2021:0972-1)NessusSuSE Local Security Checks
critical