CVE-2021-25216

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In BIND 9.5.0 -> 9.11.29, 9.12.0 -> 9.16.13, and versions BIND 9.11.3-S1 -> 9.11.29-S1 and 9.16.8-S1 -> 9.16.13-S1 of BIND Supported Preview Edition, as well as release versions 9.17.0 -> 9.17.1 of the BIND 9.17 development branch, BIND servers are vulnerable if they are running an affected version and are configured to use GSS-TSIG features. In a configuration which uses BIND's default settings the vulnerable code path is not exposed, but a server can be rendered vulnerable by explicitly setting values for the tkey-gssapi-keytab or tkey-gssapi-credential configuration options. Although the default configuration is not vulnerable, GSS-TSIG is frequently used in networks where BIND is integrated with Samba, as well as in mixed-server environments that combine BIND servers with Active Directory domain controllers. For servers that meet these conditions, the ISC SPNEGO implementation is vulnerable to various attacks, depending on the CPU architecture for which BIND was built: For named binaries compiled for 64-bit platforms, this flaw can be used to trigger a buffer over-read, leading to a server crash. For named binaries compiled for 32-bit platforms, this flaw can be used to trigger a server crash due to a buffer overflow and possibly also to achieve remote code execution. We have determined that standard SPNEGO implementations are available in the MIT and Heimdal Kerberos libraries, which support a broad range of operating systems, rendering the ISC implementation unnecessary and obsolete. Therefore, to reduce the attack surface for BIND users, we will be removing the ISC SPNEGO implementation in the April releases of BIND 9.11 and 9.16 (it had already been dropped from BIND 9.17). We would not normally remove something from a stable ESV (Extended Support Version) of BIND, but since system libraries can replace the ISC SPNEGO implementation, we have made an exception in this case for reasons of stability and security.

References

https://kb.isc.org/v1/docs/cve-2021-25215

http://www.openwall.com/lists/oss-security/2021/04/29/1

http://www.openwall.com/lists/oss-security/2021/04/29/2

http://www.openwall.com/lists/oss-security/2021/04/29/3

http://www.openwall.com/lists/oss-security/2021/04/29/4

https://www.debian.org/security/2021/dsa-4909

https://lists.debian.org/debian-lts-announce/2021/05/msg00001.html

https://security.netapp.com/advisory/ntap-20210521-0006/

https://www.zerodayinitiative.com/advisories/ZDI-21-657/

Details

Source: MITRE

Published: 2021-04-29

Updated: 2021-06-07

Type: CWE-617

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 9.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
150646SUSE SLES11 Security Update : bind (SUSE-SU-2021:14714-1)NessusSuSE Local Security Checks
critical
150437Photon OS 4.0: Bindutils PHSA-2021-4.0-0039NessusPhotonOS Local Security Checks
critical
149950Photon OS 1.0: Bindutils PHSA-2021-1.0-0391NessusPhotonOS Local Security Checks
critical
149930Photon OS 3.0: Bindutils PHSA-2021-3.0-0240NessusPhotonOS Local Security Checks
critical
149926Photon OS 2.0: Bindutils PHSA-2021-2.0-0348NessusPhotonOS Local Security Checks
critical
149315ISC BIND 9.5.0 < 9.11.31 / 9.11.3-S1 < 9.11.31-S1 / 9.12.0 < 9.16.15 / 9.16.8-S1 < 9.16.15-S1 / 9.17.0 <-> 9.17.1 Buffer Overflow (CVE-2021-25216)NessusDNS
critical
149269SUSE SLES12 Security Update : bind (SUSE-SU-2021:1469-1)NessusSuSE Local Security Checks
critical
149262Debian DLA-2647-1 : bind9 security updateNessusDebian Local Security Checks
critical
149229Debian DSA-4909-1 : bind9 - security updateNessusDebian Local Security Checks
critical
149210ISC BIND GSS-TSIG SPNEGO Buffer Overflow (CVE-2021-25216)NessusDNS
critical
149092Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 / 21.04 : Bind vulnerabilities (USN-4929-1)NessusUbuntu Local Security Checks
critical
149067Slackware 14.0 / 14.1 / 14.2 / current : bind (SSA:2021-118-01)NessusSlackware Local Security Checks
critical