CVE-2021-25215

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In BIND 9.0.0 -> 9.11.29, 9.12.0 -> 9.16.13, and versions BIND 9.9.3-S1 -> 9.11.29-S1 and 9.16.8-S1 -> 9.16.13-S1 of BIND Supported Preview Edition, as well as release versions 9.17.0 -> 9.17.11 of the BIND 9.17 development branch, when a vulnerable version of named receives a query for a record triggering the flaw described above, the named process will terminate due to a failed assertion check. The vulnerability affects all currently maintained BIND 9 branches (9.11, 9.11-S, 9.16, 9.16-S, 9.17) as well as all other versions of BIND 9.

References

https://kb.isc.org/v1/docs/cve-2021-25215

http://www.openwall.com/lists/oss-security/2021/04/29/1

http://www.openwall.com/lists/oss-security/2021/04/29/2

http://www.openwall.com/lists/oss-security/2021/04/29/3

http://www.openwall.com/lists/oss-security/2021/04/29/4

https://www.debian.org/security/2021/dsa-4909

https://lists.debian.org/debian-lts-announce/2021/05/msg00001.html

https://lists.fedoraproject.org/archives/list/[email protected]/message/VEC2XG4Q2ODTN2C4CGXEIXU3EUTBMK7L/

https://lists.fedoraproject.org/archives/list/[email protected]/message/ZDSRPCJQ7MZC6CENH5PO3VQOFI7VSWBE/

https://security.netapp.com/advisory/ntap-20210521-0006/

https://www.oracle.com/security-alerts/cpuoct2021.html

Details

Source: MITRE

Published: 2021-04-29

Updated: 2021-10-20

Type: CWE-617

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (48 total)

IDNameProductFamilySeverity
155782RHEL 6 : bind (RHSA-2021:1468)NessusRed Hat Local Security Checks
high
154688F5 Networks BIG-IP : BIND vulnerability (K96223611)NessusF5 Networks Local Security Checks
high
154527NewStart CGSL CORE 5.04 / MAIN 5.04 : bind Multiple Vulnerabilities (NS-SA-2021-0106)NessusNewStart CGSL Local Security Checks
high
154393EulerOS 2.0 SP3 : bind (EulerOS-SA-2021-2572)NessusHuawei Local Security Checks
high
153289EulerOS 2.0 SP2 : bind (EulerOS-SA-2021-2354)NessusHuawei Local Security Checks
high
153067EulerOS 2.0 SP5 : bind (EulerOS-SA-2021-2320)NessusHuawei Local Security Checks
high
152309EulerOS 2.0 SP9 : bind (EulerOS-SA-2021-2236)NessusHuawei Local Security Checks
high
152299EulerOS 2.0 SP9 : bind (EulerOS-SA-2021-2262)NessusHuawei Local Security Checks
high
152152AIX 7.2 TL 4 : bind (IJ33278)NessusAIX Local Security Checks
high
152151AIX 7.2 TL 3 : bind (IJ33277)NessusAIX Local Security Checks
high
152149AIX 7.2 TL 5 : bind (IJ33279)NessusAIX Local Security Checks
high
152148AIX 7.1 TL 5 : bind (IJ33276)NessusAIX Local Security Checks
high
151729openSUSE 15 Security Update : bind (openSUSE-SU-2021:1826-1)NessusSuSE Local Security Checks
high
151543EulerOS Virtualization 2.9.0 : bind (EulerOS-SA-2021-2194)NessusHuawei Local Security Checks
high
151538EulerOS Virtualization 2.9.1 : bind (EulerOS-SA-2021-2180)NessusHuawei Local Security Checks
high
151514Amazon Linux AMI : bind (ALAS-2021-1508)NessusAmazon Linux Local Security Checks
high
151313EulerOS Virtualization for ARM 64 3.0.2.0 : bind (EulerOS-SA-2021-2092)NessusHuawei Local Security Checks
high
151184EulerOS Virtualization for ARM 64 3.0.6.0 : bind (EulerOS-SA-2021-2013)NessusHuawei Local Security Checks
high
151039EulerOS 2.0 SP8 : bind (EulerOS-SA-2021-1975)NessusHuawei Local Security Checks
high
150646SUSE SLES11 Security Update : bind (SUSE-SU-2021:14714-1)NessusSuSE Local Security Checks
critical
150437Photon OS 4.0: Bindutils PHSA-2021-4.0-0039NessusPhotonOS Local Security Checks
critical
150215SUSE SLED15 / SLES15 Security Update : bind (SUSE-SU-2021:1826-1)NessusSuSE Local Security Checks
high
149993Oracle Linux 8 : bind (ELSA-2021-1989)NessusOracle Linux Local Security Checks
high
149950Photon OS 1.0: Bindutils PHSA-2021-1.0-0391NessusPhotonOS Local Security Checks
critical
149930Photon OS 3.0: Bindutils PHSA-2021-3.0-0240NessusPhotonOS Local Security Checks
critical
149926Photon OS 2.0: Bindutils PHSA-2021-2.0-0348NessusPhotonOS Local Security Checks
critical
149860Amazon Linux 2 : bind (ALAS-2021-1635)NessusAmazon Linux Local Security Checks
high
149760RHEL 8 : bind (RHSA-2021:2028)NessusRed Hat Local Security Checks
high
149720RHEL 8 : bind (RHSA-2021:2024)NessusRed Hat Local Security Checks
high
149711RHEL 8 : bind (RHSA-2021:1989)NessusRed Hat Local Security Checks
high
149636openSUSE Security Update : bind (openSUSE-2021-668)NessusSuSE Local Security Checks
high
149279SUSE SLES12 Security Update : bind (SUSE-SU-2021:1468-1)NessusSuSE Local Security Checks
high
149276SUSE SLED15 / SLES15 Security Update : bind (SUSE-SU-2021:1471-1)NessusSuSE Local Security Checks
high
149269SUSE SLES12 Security Update : bind (SUSE-SU-2021:1469-1)NessusSuSE Local Security Checks
critical
149262Debian DLA-2647-1 : bind9 security updateNessusDebian Local Security Checks
critical
149243RHEL 7 : bind (RHSA-2021:1476)NessusRed Hat Local Security Checks
high
149242RHEL 7 : bind (RHSA-2021:1478)NessusRed Hat Local Security Checks
high
149241RHEL 7 : bind (RHSA-2021:1477)NessusRed Hat Local Security Checks
high
149240RHEL 7 : bind (RHSA-2021:1475)NessusRed Hat Local Security Checks
high
149239RHEL 7 : bind (RHSA-2021:1479)NessusRed Hat Local Security Checks
high
149229Debian DSA-4909-1 : bind9 - security updateNessusDebian Local Security Checks
critical
149214Oracle Linux 6 : bind (ELSA-2021-9213)NessusOracle Linux Local Security Checks
high
149213Oracle Linux 7 : bind (ELSA-2021-1469)NessusOracle Linux Local Security Checks
high
149211ISC BIND DNAME Recursion DoS (CVE-2021-25215)NessusDNS
high
149205CentOS 7 : bind (CESA-2021:1469)NessusCentOS Local Security Checks
high
149092Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 / 21.04 : Bind vulnerabilities (USN-4929-1)NessusUbuntu Local Security Checks
critical
149091RHEL 7 : bind (RHSA-2021:1469)NessusRed Hat Local Security Checks
high
149067Slackware 14.0 / 14.1 / 14.2 / current : bind (SSA:2021-118-01)NessusSlackware Local Security Checks
critical