CVE-2021-22930

critical

Description

Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

References

https://hackerone.com/reports/1238162

https://nodejs.org/en/blog/vulnerability/july-2021-security-releases-2/

https://security.netapp.com/advisory/ntap-20211112-0002/

https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf

Details

Source: MITRE

Published: 2021-10-07

Updated: 2022-04-06

Type: CWE-416

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL