CVE-2021-22214

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

When requests to the internal network for webhooks are enabled, a server-side request forgery vulnerability in GitLab CE/EE affecting all versions starting from 10.5 was possible to exploit for an unauthenticated attacker even on a GitLab instance where registration is limited

References

https://gitlab.com/gitlab-org/gitlab/-/issues/322926

https://hackerone.com/reports/1110131

https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22214.json

Details

Source: MITRE

Published: 2021-06-08

Updated: 2021-06-16

Type: CWE-918

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.6

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Impact Score: 4

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (1 total)

IDNameProductFamilySeverity
152483GitLab SSRF (CVE-2021-22214)NessusMisc.
high