CVE-2021-21684

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Jenkins Git Plugin 4.8.2 and earlier does not escape the Git SHA-1 checksum parameters provided to commit notifications when displaying them in a build cause, resulting in a stored cross-site scripting (XSS) vulnerability.

References

https://www.jenkins.io/security/advisory/2021-10-06/#SECURITY-2499

http://www.openwall.com/lists/oss-security/2021/10/06/1

Details

Source: MITRE

Published: 2021-10-06

Updated: 2021-10-15

Type: CWE-79

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 6.1

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Impact Score: 2.7

Exploitability Score: 2.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:jenkins:git:*:*:*:*:*:jenkins:*:* versions up to 4.8.2 (inclusive)

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
155661Jenkins Enterprise and Operations Center < 2.249.33.0.1 / 2.277.42.0.1 / 2.303.2.5 Multiple Vulnerabilities (CloudBees Security Advisory 2021-10-06)NessusCGI abuses
medium
155627Jenkins Git Plugin < 4.8.3 XSSNessusCGI abuses
medium
154055Jenkins LTS < 2.303.2 / Jenkins weekly < 2.315 Multiple VulnerabilitiesNessusCGI abuses
medium
153924Jenkins Git Plugin < 4.8.3 / Jenkins LTS < 2.303.2 / Jenkins weekly < 2.315 Multiple Vulnerabilities (Deprecated)NessusCGI abuses
medium