CVE-2021-21648

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Jenkins Credentials Plugin 2.3.18 and earlier does not escape user-controlled information on a view it provides, resulting in a reflected cross-site scripting (XSS) vulnerability.

References

https://www.jenkins.io/security/advisory/2021-05-11/#SECURITY-2349

Details

Source: MITRE

Published: 2021-05-11

Updated: 2021-05-14

Type: CWE-79

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 6.1

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Impact Score: 2.7

Exploitability Score: 2.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:jenkins:credentials:*:*:*:*:*:jenkins:*:* versions up to 2.3.18 (inclusive)

Tenable Plugins

View all (2 total)

IDNameProductFamilySeverity
154965Jenkins Enterprise and Operations Center < 2.249.31.0.4 / 2.277.4.3 Multiple Vulnerabilities (CloudBees Security Advisory 2021-05-11)NessusCGI abuses
high
152103RHEL 7 / 8 : OpenShift Container Platform 4.8.2 packages and (RHSA-2021:2437)NessusRed Hat Local Security Checks
high