CVE-2021-21640

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Jenkins 2.286 and earlier, LTS 2.277.1 and earlier does not properly check that a newly created view has an allowed name, allowing attackers with View/Create permission to create views with invalid or already-used names.

References

https://www.jenkins.io/security/advisory/2021-04-07/#SECURITY-1871

http://www.openwall.com/lists/oss-security/2021/04/07/2

Details

Source: MITRE

Published: 2021-04-07

Updated: 2021-04-13

Type: CWE-240

Risk Information

CVSS v2

Base Score: 4

Vector: AV:N/AC:L/Au:S/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8

Severity: MEDIUM

CVSS v3

Base Score: 4.3

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Impact Score: 1.4

Exploitability Score: 2.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* versions up to 2.277.1 (inclusive)

cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* versions up to 2.286 (inclusive)

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
155586Jenkins Enterprise and Operations Center < 2.222.43.0.4 / 2.249.30.0.4 / 2.277.2.3 Multiple Vulnerabilities (CloudBees Security Advisory 2021-04-07)NessusCGI abuses
medium
152103RHEL 7 / 8 : OpenShift Container Platform 4.8.2 packages and (RHSA-2021:2437)NessusRed Hat Local Security Checks
high
148418Jenkins LTS < 2.277.2 / Jenkins weekly < 2.287 Multiple VulnerabilitiesNessusCGI abuses
medium