CVE-2021-1227

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A vulnerability in the NX-API feature of Cisco NX-OS Software could allow an unauthenticated, remote attacker to conduct a cross-site request forgery (CSRF) attack on an affected system. This vulnerability is due to insufficient CSRF protections for the NX-API on an affected device. An attacker could exploit this vulnerability by persuading a user of the NX-API to follow a malicious link. A successful exploit could allow the attacker to perform arbitrary actions with the privilege level of the affected user. The attacker could view and modify the device configuration. Note: The NX-API feature is disabled by default.

References

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-nxos-nxapi-csrf-wRMzWL9z

Details

Source: MITRE

Published: 2021-02-24

Updated: 2021-03-03

Type: CWE-352

Risk Information

CVSS v2

Base Score: 5.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N

Impact Score: 4.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.1

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

Impact Score: 5.2

Exploitability Score: 2.8

Severity: HIGH

Vulnerable Software

Configuration 1

AND

OR

cpe:2.3:o:cisco:nx-os:8.4\(2a\):*:*:*:*:*:*:*

cpe:2.3:o:cisco:nx-os:8.4\(3\):*:*:*:*:*:*:*

cpe:2.3:o:cisco:nx-os:8.4\(3\)s19:*:*:*:*:*:*:*

OR

cpe:2.3:h:cisco:mds_9148s:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:mds_9250i:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:mds_9706:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:mds_9710:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_7000:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_7700:-:*:*:*:*:*:*:*

Configuration 2

AND

OR

cpe:2.3:o:cisco:nx-os:9.3\(3\)idi9\(0.569\):*:*:*:*:*:*:*

OR

cpe:2.3:h:cisco:nexus_3048:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_31108pv-v:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_31108tc-v:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_31128pq:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3132c-z:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3132q-v:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3132q-x:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3132q-xl:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3164q:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3172pq:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3172pq-xl:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3232c:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3264c-e:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3264q:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3408-s:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_34180yc:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3432d-s:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3464c:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3524-x:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3524-xl:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3548-x:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3548-xl:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_36180yc-r:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_3636c-r:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_9200:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_9300:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_9500:-:*:*:*:*:*:*:*

Configuration 3

AND

OR

cpe:2.3:o:cisco:nx-os:7.3\(8\)n1\(0.809\):*:*:*:*:*:*:*

OR

cpe:2.3:h:cisco:nexus_5548p:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_5548up:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_5596t:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_5596up:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_56128p:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_5624q:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_5648q:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_5672up:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_5672up-16g:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_5696q:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_6001:-:*:*:*:*:*:*:*

cpe:2.3:h:cisco:nexus_6004:-:*:*:*:*:*:*:*

Tenable Plugins

View all (1 total)

IDNameProductFamilySeverity
146805Cisco NX-OS Software NX-API Cross-Site Request Forgery Vulnerability (cisco-sa-nxos-nxapi-csrf-wRMzWL9z)NessusCISCO
high