CVE-2020-6797

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

By downloading a file with the .fileloc extension, a semi-privileged extension could launch an arbitrary application on the user's computer. The attacker is restricted as they are unable to download non-quarantined files or supply command line arguments to the application, limiting the impact. Note: this issue only occurs on Mac OSX. Other operating systems are unaffected. This vulnerability affects Thunderbird < 68.5, Firefox < 73, and Firefox < ESR68.5.

References

https://bugzilla.mozilla.org/show_bug.cgi?id=1596668

https://www.mozilla.org/security/advisories/mfsa2020-06/

https://www.mozilla.org/security/advisories/mfsa2020-07/

https://www.mozilla.org/security/advisories/mfsa2020-05/

https://security.gentoo.org/glsa/202003-02

Details

Source: MITRE

Published: 2020-03-02

Updated: 2021-09-16

Type: CWE-20

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 4.3

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Impact Score: 1.4

Exploitability Score: 2.8

Severity: MEDIUM

Tenable Plugins

View all (11 total)

IDNameProductFamilySeverity
150679SUSE SLES11 Security Update : MozillaFirefox (SUSE-SU-2020:14290-1)NessusSuSE Local Security Checks
high
134469GLSA-202003-02 : Mozilla Firefox: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
133849Mozilla Firefox ESR < 68.5 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
133762SUSE SLED12 / SLES12 Security Update : MozillaFirefox (SUSE-SU-2020:0384-1)NessusSuSE Local Security Checks
high
133761SUSE SLED15 / SLES15 Security Update : MozillaFirefox (SUSE-SU-2020:0383-1)NessusSuSE Local Security Checks
high
133760openSUSE Security Update : MozillaThunderbird (openSUSE-2020-231)NessusSuSE Local Security Checks
high
133759openSUSE Security Update : MozillaFirefox (openSUSE-2020-230)NessusSuSE Local Security Checks
high
133692Mozilla Firefox < 73.0NessusMacOS X Local Security Checks
high
133690Mozilla Thunderbird < 68.5NessusMacOS X Local Security Checks
high
133643Slackware 14.2 / current : mozilla-thunderbird (SSA:2020-042-02)NessusSlackware Local Security Checks
high
133642Slackware 14.2 / current : mozilla-firefox (SSA:2020-042-01)NessusSlackware Local Security Checks
high