CVE-2020-3878

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An out-of-bounds read was addressed with improved input validation. This issue is fixed in iOS 13.5 and iPadOS 13.5, macOS Catalina 10.15.5, tvOS 13.4.5, watchOS 6.2.5, iTunes 12.10.7 for Windows, iCloud for Windows 11.2, iCloud for Windows 7.19. Processing a maliciously crafted image may lead to arbitrary code execution.

References

https://support.apple.com/HT211168

https://support.apple.com/HT211170

https://support.apple.com/HT211171

https://support.apple.com/HT211175

https://support.apple.com/HT211178

https://support.apple.com/HT211179

https://support.apple.com/HT211181

Details

Source: MITRE

Published: 2020-02-27

Updated: 2020-06-09

Type: CWE-125

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 7.8

Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
136930macOS 10.15.x < 10.15.5 / 10.14.x < 10.14.6 Security Update 2020-003 / 10.13.x < 10.13.6 Security Update 2020-003NessusMacOS X Local Security Checks
high
136920Apple iOS < 13.5 Multiple VulnerabilitiesNessusMobile Devices
high
133727Apple TV < 13.3.1 Multiple VulnerabilitiesNessusMisc.
high
133531macOS 10.15.x < 10.15.3 / 10.14.x < 10.14.6 / 10.13.x < 10.13.6NessusMacOS X Local Security Checks
critical
133528Apple iOS < 13.3.1 Multiple VulnerabilitiesNessusMobile Devices
high