CVE-2020-35458

HIGH

Description

An issue was discovered in ClusterLabs Hawk 2.x through 2.3.0-x. There is a Ruby shell code injection issue via the hawk_remember_me_id parameter in the login_from_cookie cookie. The user logout routine could be used by unauthenticated remote attackers to execute code as hauser.

References

http://www.openwall.com/lists/oss-security/2021/01/12/3

https://bugzilla.suse.com/show_bug.cgi?id=1179998

https://github.com/ClusterLabs/hawk/releases

https://www.openwall.com/lists/oss-security/2021/01/12/3

Details

Source: MITRE

Published: 2021-01-12

Updated: 2021-01-21

Type: CWE-94

Risk Information

CVSS v2.0

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
145390openSUSE Security Update : hawk2 (openSUSE-2021-54)NessusSuSE Local Security Checks
critical
145387openSUSE Security Update : hawk2 (openSUSE-2021-74)NessusSuSE Local Security Checks
critical
145339openSUSE Security Update : hawk2 (openSUSE-2021-147)NessusSuSE Local Security Checks
critical
145311openSUSE Security Update : hawk2 (openSUSE-2021-144)NessusSuSE Local Security Checks
critical