CVE-2020-29367

HIGH

Description

blosc2.c in Blosc C-Blosc2 through 2.0.0.beta.5 has a heap-based buffer overflow when there is a lack of space to write compressed data.

References

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=26442

https://github.com/Blosc/c-blosc2/commit/c4c6470e88210afc95262c8b9fcc27e30ca043ee

Details

Source: MITRE

Published: 2020-11-27

Updated: 2020-12-03

Type: CWE-787

Risk Information

CVSS v2.0

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH

Tenable Plugins

View all (1 total)

IDNameProductFamilySeverity
145345openSUSE Security Update : blosc (openSUSE-2020-2337)NessusSuSE Local Security Checks
high