CVE-2020-27843

medium

Description

A flaw was found in OpenJPEG in versions prior to 2.4.0. This flaw allows an attacker to provide specially crafted input to the conversion or encoding functionality, causing an out-of-bounds read. The highest threat from this vulnerability is system availability.

References

https://bugzilla.redhat.com/show_bug.cgi?id=1907516

https://lists.fedoraproject.org/archives/list/[email protected]/message/WJUPGIZE6A4O52EBOF75MCXJOL6MUCRV/

https://security.gentoo.org/glsa/202101-29

https://www.debian.org/security/2021/dsa-4882

https://www.oracle.com/security-alerts/cpuApr2021.html

https://www.oracle.com//security-alerts/cpujul2021.html

https://lists.debian.org/debian-lts-announce/2022/04/msg00006.html

Details

Source: MITRE

Published: 2021-01-05

Updated: 2022-06-16

Type: CWE-125

Risk Information

CVSS v2

Base Score: 7.1

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 8.6

Severity: HIGH

CVSS v3

Base Score: 5.5

Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM