CVE-2020-27777

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A flaw was found in the way RTAS handled memory accesses in userspace to kernel communication. On a locked down (usually due to Secure Boot) guest system running on top of PowerVM or KVM hypervisors (pseries platform) a root like local user could use this flaw to further increase their privileges to that of a running kernel.

References

https://bugzilla.redhat.com/show_bug.cgi?id=1900844

https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git/commit/?h=next&id=bd59380c5ba4147dcbaad3e582b55ccfd120b764

https://www.openwall.com/lists/oss-security/2020/10/09/1

https://www.openwall.com/lists/oss-security/2020/11/23/2

Details

Source: MITRE

Published: 2020-12-15

Updated: 2020-12-22

Type: CWE-862

Risk Information

CVSS v2

Base Score: 7.2

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.9

Severity: HIGH

CVSS v3

Base Score: 6.7

Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 0.8

Severity: MEDIUM

Tenable Plugins

View all (40 total)

IDNameProductFamilySeverity
151229EulerOS Virtualization 3.0.6.6 : kernel (EulerOS-SA-2021-2040)NessusHuawei Local Security Checks
high
150536SUSE SLES11 Security Update : kernel (SUSE-SU-2021:14630-1)NessusSuSE Local Security Checks
high
149098EulerOS 2.0 SP3 : kernel (EulerOS-SA-2021-1808)NessusHuawei Local Security Checks
high
148041EulerOS 2.0 SP5 : kernel (EulerOS-SA-2021-1684)NessusHuawei Local Security Checks
high
147978Ubuntu 20.04 LTS / 20.10 : Linux kernel vulnerabilities (USN-4751-1)NessusUbuntu Local Security Checks
high
147690EulerOS Virtualization 2.9.0 : kernel (EulerOS-SA-2021-1642)NessusHuawei Local Security Checks
high
147512EulerOS Virtualization 2.9.1 : kernel (EulerOS-SA-2021-1604)NessusHuawei Local Security Checks
high
146701EulerOS 2.0 SP2 : kernel (EulerOS-SA-2021-1311)NessusHuawei Local Security Checks
high
146511SUSE SLES12 Security Update : kernel (SUSE-SU-2021:0452-1)NessusSuSE Local Security Checks
high
146476SUSE SLES12 Security Update : kernel (SUSE-SU-2021:0437-1)NessusSuSE Local Security Checks
high
146474SUSE SLES15 Security Update : kernel (SUSE-SU-2021:0438-1)NessusSuSE Local Security Checks
high
146470SUSE SLES12 Security Update : kernel (SUSE-SU-2021:0434-1)NessusSuSE Local Security Checks
high
146282openSUSE Security Update : RT kernel (openSUSE-2021-242)NessusSuSE Local Security Checks
high
145510Ubuntu 16.04 LTS : Linux kernel vulnerabilities (USN-4708-1)NessusUbuntu Local Security Checks
high
145320openSUSE Security Update : the Linux Kernel (openSUSE-2021-60)NessusSuSE Local Security Checks
medium
145287openSUSE Security Update : the Linux Kernel (openSUSE-2021-75)NessusSuSE Local Security Checks
medium
145120SUSE SLES12 Security Update : kernel (SUSE-SU-2021:0133-1)NessusSuSE Local Security Checks
medium
145025SUSE SLED15 / SLES15 Security Update : kernel (SUSE-SU-2021:0117-1)NessusSuSE Local Security Checks
medium
145018SUSE SLED15 / SLES15 Security Update : kernel (SUSE-SU-2021:0118-1)NessusSuSE Local Security Checks
medium
145005Amazon Linux AMI : kernel (ALAS-2021-1461)NessusAmazon Linux Local Security Checks
medium
144959SUSE SLES15 Security Update : kernel (SUSE-SU-2021:0108-1)NessusSuSE Local Security Checks
medium
144914SUSE SLES12 Security Update : kernel (SUSE-SU-2021:0098-1)NessusSuSE Local Security Checks
high
144908SUSE SLES15 Security Update : kernel (SUSE-SU-2021:0095-1)NessusSuSE Local Security Checks
medium
144750Ubuntu 18.04 LTS / 20.04 LTS : Linux kernel vulnerabilities (USN-4679-1)NessusUbuntu Local Security Checks
medium
144749Ubuntu 16.04 LTS / 18.04 LTS : Linux kernel vulnerabilities (USN-4680-1)NessusUbuntu Local Security Checks
medium
144731EulerOS Virtualization for ARM 64 3.0.2.0 : kernel (EulerOS-SA-2021-1039)NessusHuawei Local Security Checks
high
144693EulerOS 2.0 SP9 : kernel (EulerOS-SA-2021-1028)NessusHuawei Local Security Checks
high
144687EulerOS 2.0 SP9 : kernel (EulerOS-SA-2021-1009)NessusHuawei Local Security Checks
high
144464Amazon Linux AMI : kernel (ALAS-2020-1462) (deprecated)NessusAmazon Linux Local Security Checks
high
144313openSUSE Security Update : the Linux Kernel (openSUSE-2020-2260)NessusSuSE Local Security Checks
medium
144259SUSE SLES15 Security Update : kernel (SUSE-SU-2020:3798-1)NessusSuSE Local Security Checks
high
144168EulerOS 2.0 SP8 : kernel (EulerOS-SA-2020-2514)NessusHuawei Local Security Checks
medium
144143SUSE SLES15 Security Update : kernel (SUSE-SU-2020:3764-1)NessusSuSE Local Security Checks
high
144101SUSE SLED15 / SLES15 Security Update : kernel (SUSE-SU-2020:3748-1)NessusSuSE Local Security Checks
medium
143860SUSE SLES12 Security Update : kernel (SUSE-SU-2020:3717-1)NessusSuSE Local Security Checks
medium
143633SUSE SLED15 / SLES15 Security Update : kernel (SUSE-SU-2020:3718-1)NessusSuSE Local Security Checks
medium
143619SUSE SLES12 Security Update : kernel (SUSE-SU-2020:3715-1)NessusSuSE Local Security Checks
medium
143589Amazon Linux 2 : kernel (ALAS-2020-1566)NessusAmazon Linux Local Security Checks
medium
143542openSUSE Security Update : the Linux Kernel (openSUSE-2020-2193)NessusSuSE Local Security Checks
medium
143523openSUSE Security Update : the Linux Kernel (openSUSE-2020-2161)NessusSuSE Local Security Checks
medium