CVE-2020-26989

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A vulnerability has been identified in JT2Go (All versions < V13.1.0.1), Solid Edge SE2020 (All Versions < SE2020MP12), Solid Edge SE2021 (All Versions < SE2021MP2), Teamcenter Visualization (All versions < V13.1.0.1). Affected applications lack proper validation of user-supplied data when parsing of PAR files. This could result in a stack based buffer overflow. An attacker could leverage this vulnerability to execute code in the context of the current process. (ZDI-CAN-11892)

References

https://cert-portal.siemens.com/productcert/pdf/ssa-979834.pdf

https://cert-portal.siemens.com/productcert/pdf/ssa-622830.pdf

https://www.zerodayinitiative.com/advisories/ZDI-21-050/

https://cert-portal.siemens.com/productcert/pdf/ssa-663999.pdf

Details

Source: MITRE

Published: 2021-01-12

Updated: 2021-07-23

Type: CWE-121

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 7.8

Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH

Tenable Plugins

View all (1 total)

IDNameProductFamilySeverity
149326Siemens JT2Go < 13.1.0.1 Multiple Vulnerabilities (SSA-663999)NessusWindows
high