CVE-2020-26682

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In libass 0.14.0, the `ass_outline_construct`'s call to `outline_stroke` causes a signed integer overflow.

References

http://www.openwall.com/lists/oss-security/2020/11/19/7

https://github.com/libass/libass/issues/431

https://github.com/libass/libass/pull/432

https://security.gentoo.org/glsa/202012-12

Details

Source: MITRE

Published: 2020-10-16

Updated: 2020-12-23

Type: CWE-190

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:libass_project:libass:0.14.0:*:*:*:*:*:*:*

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
148177SUSE SLED15 / SLES15 Security Update : libass (SUSE-SU-2021:0936-1)NessusSuSE Local Security Checks
high
148153openSUSE Security Update : libass (openSUSE-2021-472)NessusSuSE Local Security Checks
high
144591GLSA-202012-12 : libass: User-assisted execution of arbitrary codeNessusGentoo Local Security Checks
high