CVE-2020-2574

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Vulnerability in the MySQL Client product of Oracle MySQL (component: C API). Supported versions that are affected are 5.6.46 and prior, 5.7.28 and prior and 8.0.18 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise MySQL Client. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Client. CVSS 3.0 Base Score 5.9 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H).

References

https://www.oracle.com/security-alerts/cpujan2020.html

https://security.netapp.com/advisory/ntap-20200122-0002/

https://usn.ubuntu.com/4250-1/

https://usn.ubuntu.com/4250-2/

http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00007.html

http://www.openwall.com/lists/oss-security/2020/09/29/1

https://security.gentoo.org/glsa/202105-27

Details

Source: MITRE

Published: 2020-01-15

Updated: 2021-05-26

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.9

Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.2

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:oracle:mysql:*:*:*:*:*:*:*:* versions from 5.6.0 to 5.6.46 (inclusive)

cpe:2.3:a:oracle:mysql:*:*:*:*:*:*:*:* versions from 5.7.0 to 5.7.28 (inclusive)

cpe:2.3:a:oracle:mysql:*:*:*:*:*:*:*:* versions from 8.0.0 to 8.0.18 (inclusive)

Tenable Plugins

View all (49 total)

IDNameProductFamilySeverity
154603NewStart CGSL CORE 5.05 / MAIN 5.05 : mariadb Multiple Vulnerabilities (NS-SA-2021-0162)NessusNewStart CGSL Local Security Checks
high
154600NewStart CGSL MAIN 6.02 : mariadb-connector-c Multiple Vulnerabilities (NS-SA-2021-0123)NessusNewStart CGSL Local Security Checks
high
151404EulerOS Virtualization 3.0.2.2 : mariadb (EulerOS-SA-2021-2148)NessusHuawei Local Security Checks
medium
149184EulerOS 2.0 SP3 : mariadb (EulerOS-SA-2021-1815)NessusHuawei Local Security Checks
medium
147585EulerOS Virtualization 3.0.2.6 : mariadb (EulerOS-SA-2021-1443)NessusHuawei Local Security Checks
medium
147291NewStart CGSL CORE 5.04 / MAIN 5.04 : mariadb Multiple Vulnerabilities (NS-SA-2021-0023)NessusNewStart CGSL Local Security Checks
medium
147260NewStart CGSL MAIN 6.02 : mariadb-connector-c Multiple Vulnerabilities (NS-SA-2021-0090)NessusNewStart CGSL Local Security Checks
high
147100EulerOS Virtualization 3.0.6.6 : mariadb (EulerOS-SA-2021-1498)NessusHuawei Local Security Checks
medium
146114EulerOS 2.0 SP5 : mariadb (EulerOS-SA-2021-1213)NessusHuawei Local Security Checks
medium
146017CentOS 8 : mariadb:10.3 (CESA-2020:5500)NessusCentOS Local Security Checks
critical
145920CentOS 8 : mariadb-connector-c (CESA-2020:5503)NessusCentOS Local Security Checks
high
145871CentOS 8 : mysql:8.0 (CESA-2020:3732)NessusCentOS Local Security Checks
high
144721EulerOS Virtualization for ARM 64 3.0.2.0 : mariadb (EulerOS-SA-2021-1055)NessusHuawei Local Security Checks
medium
144558RHEL 8 : mariadb-connector-c (RHSA-2020:5662)NessusRed Hat Local Security Checks
high
144557RHEL 8 : mariadb-connector-c (RHSA-2020:5655)NessusRed Hat Local Security Checks
high
144556RHEL 8 : mariadb-connector-c (RHSA-2020:5660)NessusRed Hat Local Security Checks
high
144555RHEL 8 : mariadb:10.3 (RHSA-2020:5663)NessusRed Hat Local Security Checks
critical
144550RHEL 8 : mariadb:10.3 (RHSA-2020:5665)NessusRed Hat Local Security Checks
critical
144548RHEL 8 : mariadb:10.3 (RHSA-2020:5654)NessusRed Hat Local Security Checks
critical
144418RHEL 8 : mariadb:10.3 (RHSA-2020:5500)NessusRed Hat Local Security Checks
critical
144383RHEL 8 : mariadb-connector-c (RHSA-2020:5503)NessusRed Hat Local Security Checks
high
144375Oracle Linux 8 : mariadb:10.3 (ELSA-2020-5500)NessusOracle Linux Local Security Checks
critical
144373Oracle Linux 8 : ELSA-2020-5503-1: / mariadb-connector-c (ELSA-2020-55031)NessusOracle Linux Local Security Checks
high
143030RHEL 8 : mysql:8.0 (RHSA-2020:3732)NessusRed Hat Local Security Checks
high
142022Amazon Linux 2 : mariadb (ALAS-2020-1537)NessusAmazon Linux Local Security Checks
low
141723Scientific Linux Security Update : mariadb on SL7.x x86_64 (20201001)NessusScientific Linux Local Security Checks
medium
141610CentOS 7 : mariadb (CESA-2020:4026)NessusCentOS Local Security Checks
medium
141035RHEL 7 : mariadb (RHSA-2020:4026)NessusRed Hat Local Security Checks
medium
140614Oracle Linux 8 : mysql:8.0 (ELSA-2020-3732)NessusOracle Linux Local Security Checks
high
140599RHEL 8 : mysql:8.0 (RHSA-2020:3757)NessusRed Hat Local Security Checks
high
140598RHEL 8 : mysql:8.0 (RHSA-2020:3755)NessusRed Hat Local Security Checks
high
135872Photon OS 3.0: Mysql PHSA-2020-3.0-0082NessusPhotonOS Local Security Checks
medium
134835Photon OS 1.0: Mysql PHSA-2020-1.0-0284NessusPhotonOS Local Security Checks
medium
134280openSUSE Security Update : mariadb (openSUSE-2020-289)NessusSuSE Local Security Checks
medium
134200SUSE SLES12 Security Update : mariadb-100 (SUSE-SU-2020:0523-1)NessusSuSE Local Security Checks
medium
134158SUSE SLES12 Security Update : mariadb (SUSE-SU-2020:0505-1)NessusSuSE Local Security Checks
medium
134105SUSE SLED15 / SLES15 Security Update : mariadb (SUSE-SU-2020:0496-1)NessusSuSE Local Security Checks
medium
133682MariaDB 10.2.0 < 10.2.31 A VulnerabilityNessusDatabases
medium
133681MariaDB 10.4.0 < 10.4.12 A VulnerabilityNessusDatabases
medium
133680MariaDB 5.5.0 < 5.5.67 A VulnerabilityNessusDatabases
medium
133679MariaDB 10.1.0 < 10.1.44 A VulnerabilityNessusDatabases
medium
133678MariaDB 10.3.0 < 10.3.22 A VulnerabilityNessusDatabases
medium
133548Ubuntu 18.04 LTS / 19.10 : mariadb-10.1, mariadb-10.3 vulnerability (USN-4250-2)NessusUbuntu Local Security Checks
medium
133436FreeBSD : MariaDB -- Vulnerability in C API (cb0183bb-45f6-11ea-a1c7-b499baebfeaf)NessusFreeBSD Local Security Checks
medium
133289Ubuntu 16.04 LTS / 18.04 LTS / 19.10 : MySQL vulnerabilities (USN-4250-1)NessusUbuntu Local Security Checks
low
132958MySQL 8.0.x < 8.0.19 Multiple Vulnerabilities (Jan 2020 CPU)NessusDatabases
critical
132957MySQL 5.7.x < 5.7.29 Multiple Vulnerabilities (Jan 2020 CPU)NessusDatabases
critical
132956MySQL 5.6.x < 5.6.47 Multiple Vulnerabilities (Jan 2020 CPU)NessusDatabases
medium
132942FreeBSD : MySQL -- Multiple vulerabilities (a6cf65ad-37d2-11ea-a1c7-b499baebfeaf)NessusFreeBSD Local Security Checks
critical