CVE-2020-25710

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A flaw was found in OpenLDAP in versions before 2.4.56. This flaw allows an attacker who sends a malicious packet processed by OpenLDAP to force a failed assertion in csnNormalize23(). The highest threat from this vulnerability is to system availability.

References

https://lists.debian.org/debian-lts-announce/2020/12/msg00008.html

https://git.openldap.org/openldap/openldap/-/commit/ab3915154e69920d480205b4bf5ccb2b391a0a1f#a2feb6ed0257c21c6672793ee2f94eaadc10c72c

https://www.debian.org/security/2020/dsa-4792

https://bugzilla.redhat.com/show_bug.cgi?id=1899678

https://lists.apache.org/thread.html/[email protected]%3Cissues.bookkeeper.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Cissues.bookkeeper.apache.org%3E

https://security.netapp.com/advisory/ntap-20210716-0003/

Details

Source: MITRE

Published: 2021-05-28

Updated: 2021-07-16

Type: CWE-617

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
151337EulerOS Virtualization for ARM 64 3.0.2.0 : openldap (EulerOS-SA-2021-2084)NessusHuawei Local Security Checks
high
150658SUSE SLES11 Security Update : openldap2 (SUSE-SU-2021:14597-1)NessusSuSE Local Security Checks
high
145370openSUSE Security Update : openldap2 (openSUSE-2021-102)NessusSuSE Local Security Checks
high
145278openSUSE Security Update : openldap2 (openSUSE-2021-107)NessusSuSE Local Security Checks
high
145205SUSE SLES12 Security Update : openldap2 (SUSE-SU-2021:0142-1)NessusSuSE Local Security Checks
high
145029SUSE SLES12 Security Update : openldap2 (SUSE-SU-2021:0128-1)NessusSuSE Local Security Checks
high
145026SUSE SLED15 / SLES15 Security Update : openldap2 (SUSE-SU-2021:0129-1)NessusSuSE Local Security Checks
high
143518Debian DLA-2481-1 : openldap security updateNessusDebian Local Security Checks
high
143002Debian DSA-4792-1 : openldap - security updateNessusDebian Local Security Checks
high
142966Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 : OpenLDAP vulnerabilities (USN-4634-1)NessusUbuntu Local Security Checks
high