CVE-2020-14349

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

It was found that PostgreSQL versions before 12.4, before 11.9 and before 10.14 did not properly sanitize the search_path during logical replication. An authenticated attacker could use this flaw in an attack similar to CVE-2018-1058, in order to execute arbitrary SQL command in the context of the user used for replication.

References

http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00044.html

http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00049.html

http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00050.html

http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00003.html

http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00008.html

https://bugzilla.redhat.com/show_bug.cgi?id=1865744

https://security.gentoo.org/glsa/202008-13

https://security.netapp.com/advisory/ntap-20200918-0002/

https://usn.ubuntu.com/4472-1/

Details

Source: MITRE

Published: 2020-08-24

Updated: 2020-09-18

Type: CWE-89

Risk Information

CVSS v2

Base Score: 4.6

Vector: AV:N/AC:H/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 3.9

Severity: MEDIUM

CVSS v3

Base Score: 7.1

Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.2

Severity: HIGH

Tenable Plugins

View all (28 total)

IDNameProductFamilySeverity
150722Oracle Linux 7 : rh-postgresql10-postgresql (ELSA-2021-9290)NessusOracle Linux Local Security Checks
high
148122RHEL 8 : rhvm-appliance (RHSA-2021:0988)NessusRed Hat Local Security Checks
critical
146002CentOS 8 : postgresql:12 (CESA-2020:5620)NessusCentOS Local Security Checks
high
145882CentOS 8 : postgresql:10 (CESA-2020:3669)NessusCentOS Local Security Checks
high
145243RHEL 8 : postgresql:10 (RHSA-2021:0166)NessusRed Hat Local Security Checks
high
145044RHEL 8 : postgresql:12 (RHSA-2021:0163)NessusRed Hat Local Security Checks
high
144564Oracle Linux 8 : ELSA-2020-5620-1: / postgresql:12 (ELSA-2020-56201)NessusOracle Linux Local Security Checks
high
144559RHEL 8 : postgresql:10 (RHSA-2020:5664)NessusRed Hat Local Security Checks
high
144417RHEL 8 : postgresql:12 (RHSA-2020:5620)NessusRed Hat Local Security Checks
high
143653SUSE SLES12 Security Update : postgresql12 (SUSE-SU-2020:3630-1)NessusSuSE Local Security Checks
high
141640Photon OS 1.0: Postgresql PHSA-2020-1.0-0321NessusPhotonOS Local Security Checks
high
141004EulerOS 2.0 SP8 : postgresql (EulerOS-SA-2020-2156)NessusHuawei Local Security Checks
high
140663Photon OS 2.0: Postgresql PHSA-2020-2.0-0281NessusPhotonOS Local Security Checks
high
140486Oracle Linux 8 : postgresql:10 (ELSA-2020-3669)NessusOracle Linux Local Security Checks
high
140412Photon OS 3.0: Postgresql PHSA-2020-3.0-0137NessusPhotonOS Local Security Checks
high
140398RHEL 8 : postgresql:10 (RHSA-2020:3669)NessusRed Hat Local Security Checks
high
140366openSUSE Security Update : postgresql10 (openSUSE-2020-1326)NessusSuSE Local Security Checks
high
140173openSUSE Security Update : postgresql10 (openSUSE-2020-1312)NessusSuSE Local Security Checks
high
140025SUSE SLED15 / SLES15 Security Update : postgresql10 (SUSE-SU-2020:2355-1)NessusSuSE Local Security Checks
high
139889GLSA-202008-13 : PostgreSQL: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
139848Ubuntu 16.04 LTS / 18.04 LTS / 20.04 : PostgreSQL vulnerabilities (USN-4472-1)NessusUbuntu Local Security Checks
high
139769openSUSE Security Update : postgresql12 (openSUSE-2020-1244)NessusSuSE Local Security Checks
high
139768openSUSE Security Update : postgresql12 (openSUSE-2020-1243)NessusSuSE Local Security Checks
high
139765openSUSE Security Update : postgresql / postgresql96 / postgresql10 / etc (openSUSE-2020-1228)NessusSuSE Local Security Checks
high
139746PostgreSQL 9.5.x < 9.5.23 / 9.6.x < 9.6.19 / 10.x < 10.14 / 11.x < 11.9 / 12.x < 12.4 Multiple VulnerabilitiesNessusDatabases
high
139691SUSE SLED15 / SLES15 Security Update : postgresql12 (SUSE-SU-2020:2271-1)NessusSuSE Local Security Checks
high
139687SUSE SLED15 / SLES15 Security Update : postgresql12 (SUSE-SU-2020:2265-1)NessusSuSE Local Security Checks
high
139686SUSE SLES15 Security Update : postgresql10 (SUSE-SU-2020:2264-1)NessusSuSE Local Security Checks
high