CVE-2020-14342

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

It was found that cifs-utils' mount.cifs was invoking a shell when requesting the Samba password, which could be used to inject arbitrary commands. An attacker able to invoke mount.cifs with special permission, such as via sudo rules, could use this flaw to escalate their privileges.

References

http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00109.html

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-14342

https://lists.fedoraproject.org/archives/list/[email protected]/message/DUMRICFXJVCBBOSKZSKT3HFVQM6VPJU3/

https://lists.fedoraproject.org/archives/list/[email protected]/message/JBNFSTJOQWVPFZAUJNNMAPY45PW5RTTE/

https://lists.samba.org/archive/samba-technical/2020-September/135747.html

https://security.gentoo.org/glsa/202009-16

Details

Source: MITRE

Published: 2020-09-09

Updated: 2020-11-11

Type: CWE-78

Risk Information

CVSS v2

Base Score: 4.4

Vector: AV:L/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 3.4

Severity: MEDIUM

CVSS v3

Base Score: 7

Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:samba:cifs-utils:*:*:*:*:*:*:*:* versions from 5.6 to 6.10 (inclusive)

Tenable Plugins

View all (23 total)

IDNameProductFamilySeverity
151896EulerOS Virtualization 3.0.2.2 : cifs-utils (EulerOS-SA-2021-2130)NessusHuawei Local Security Checks
high
149598openSUSE Security Update : cifs-utils (openSUSE-2021-639)NessusSuSE Local Security Checks
medium
149224SUSE SLES15 Security Update : cifs-utils (SUSE-SU-2021:1455-1)NessusSuSE Local Security Checks
medium
147687EulerOS Virtualization 2.9.0 : cifs-utils (EulerOS-SA-2021-1664)NessusHuawei Local Security Checks
high
147578EulerOS Virtualization 2.9.1 : cifs-utils (EulerOS-SA-2021-1592)NessusHuawei Local Security Checks
high
147525EulerOS Virtualization 3.0.6.6 : cifs-utils (EulerOS-SA-2021-1463)NessusHuawei Local Security Checks
high
147472EulerOS Virtualization 3.0.2.6 : cifs-utils (EulerOS-SA-2021-1409)NessusHuawei Local Security Checks
high
147052EulerOS Virtualization for ARM 64 3.0.6.0 : cifs-utils (EulerOS-SA-2021-1546)NessusHuawei Local Security Checks
high
146764EulerOS 2.0 SP2 : cifs-utils (EulerOS-SA-2021-1284)NessusHuawei Local Security Checks
high
146138EulerOS 2.0 SP5 : cifs-utils (EulerOS-SA-2021-1183)NessusHuawei Local Security Checks
high
145151EulerOS 2.0 SP3 : cifs-utils (EulerOS-SA-2021-1061)NessusHuawei Local Security Checks
high
144720EulerOS Virtualization for ARM 64 3.0.2.0 : cifs-utils (EulerOS-SA-2021-1054)NessusHuawei Local Security Checks
high
143806SUSE SLES12 Security Update : cifs-utils (SUSE-SU-2020:2728-1)NessusSuSE Local Security Checks
high
143774SUSE SLED15 / SLES15 Security Update : cifs-utils (SUSE-SU-2020:2729-1)NessusSuSE Local Security Checks
high
142842Fedora 33 : cifs-utils (2020-ea0b9caac3)NessusFedora Local Security Checks
high
142837Fedora 32 : cifs-utils (2020-cfdd73f1b4)NessusFedora Local Security Checks
high
142184EulerOS 2.0 SP8 : cifs-utils (EulerOS-SA-2020-2305)NessusHuawei Local Security Checks
high
141336EulerOS 2.0 SP9 : cifs-utils (EulerOS-SA-2020-2174)NessusHuawei Local Security Checks
high
141315EulerOS 2.0 SP9 : cifs-utils (EulerOS-SA-2020-2164)NessusHuawei Local Security Checks
high
141159openSUSE Security Update : cifs-utils (openSUSE-2020-1579)NessusSuSE Local Security Checks
high
141066GLSA-202009-16 : LinuxCIFS: Shell injectionNessusGentoo Local Security Checks
high
140712Photon OS 2.0: Cifs PHSA-2020-2.0-0285NessusPhotonOS Local Security Checks
high
140705Photon OS 3.0: Cifs PHSA-2020-3.0-0142NessusPhotonOS Local Security Checks
high