CVE-2020-14212

MEDIUM

Description

FFmpeg through 4.3 has a heap-based buffer overflow in avio_get_str in libavformat/aviobuf.c because dnn_backend_native.c calls ff_dnn_load_model_native and a certain index check is omitted.

References

https://patchwork.ffmpeg.org/project/ffmpeg/list/?series=1463

https://security.gentoo.org/glsa/202007-58

https://trac.ffmpeg.org/ticket/8716

Details

Source: MITRE

Published: 2020-06-16

Updated: 2020-09-18

Type: CWE-787

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH