CVE-2020-12387

high

Description

A race condition when running shutdown code for Web Worker led to a use-after-free vulnerability. This resulted in a potentially exploitable crash. This vulnerability affects Firefox ESR < 68.8, Firefox < 76, and Thunderbird < 68.8.0.

References

https://www.mozilla.org/security/advisories/mfsa2020-17/

https://www.mozilla.org/security/advisories/mfsa2020-18/

https://www.mozilla.org/security/advisories/mfsa2020-16/

https://bugzilla.mozilla.org/show_bug.cgi?id=1545345

https://usn.ubuntu.com/4373-1/

https://security.gentoo.org/glsa/202005-03

https://security.gentoo.org/glsa/202005-04

Details

Source: MITRE

Published: 2020-05-26

Updated: 2021-12-14

Type: CWE-362

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.1

Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.2

Severity: HIGH