CVE-2019-9497

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The implementations of EAP-PWD in hostapd EAP Server and wpa_supplicant EAP Peer do not validate the scalar and element values in EAP-pwd-Commit. This vulnerability may allow an attacker to complete EAP-PWD authentication without knowing the password. However, unless the crypto library does not implement additional checks for the EC point, the attacker will not be able to derive the session key or complete the key exchange. Both hostapd with SAE support and wpa_supplicant with SAE support prior to and including version 2.4 are affected. Both hostapd with EAP-pwd support and wpa_supplicant with EAP-pwd support prior to and including version 2.7 are affected.

References

http://packetstormsecurity.com/files/152914/FreeBSD-Security-Advisory-FreeBSD-SA-19-03.wpa.html

https://lists.debian.org/debian-lts-announce/2019/07/msg00030.html

https://lists.fedoraproject.org/archives/list/[email protected]/message/56OBBOJJSKRTDGEXZOVFSTP4HDSDBLAE/

https://lists.fedoraproject.org/archives/list/[email protected]/message/SVMJOFEYBGXZLFF5IOLW67SSOPKFEJP3/

https://lists.fedoraproject.org/archives/list/[email protected]/message/TDOZGR3T7FVO5JSZWK2QPR7AOFIEJTIZ/

https://seclists.org/bugtraq/2019/May/40

https://security.FreeBSD.org/advisories/FreeBSD-SA-19:03.wpa.asc

https://w1.fi/security/2019-4/

https://www.synology.com/security/advisory/Synology_SA_19_16

Details

Source: MITRE

Published: 2019-04-17

Updated: 2019-05-15

Type: CWE-287

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.2

Severity: HIGH

Tenable Plugins

View all (15 total)

IDNameProductFamilySeverity
143704SUSE SLES12 Security Update : wpa_supplicant (SUSE-SU-2020:3424-1) (KRACK)NessusSuSE Local Security Checks
high
143627SUSE SLED15 / SLES15 Security Update : wpa_supplicant (SUSE-SU-2020:3380-1) (KRACK)NessusSuSE Local Security Checks
high
143321openSUSE Security Update : wpa_supplicant (openSUSE-2020-2053) (KRACK)NessusSuSE Local Security Checks
high
143304openSUSE Security Update : wpa_supplicant (openSUSE-2020-2059) (KRACK)NessusSuSE Local Security Checks
high
133758openSUSE Security Update : hostapd (openSUSE-2020-222) (KRACK)NessusSuSE Local Security Checks
high
132827EulerOS Virtualization for ARM 64 3.0.5.0 : wpa_supplicant (EulerOS-SA-2020-1073)NessusHuawei Local Security Checks
high
132629EulerOS 2.0 SP8 : wpa_supplicant (EulerOS-SA-2020-1036)NessusHuawei Local Security Checks
high
127476Debian DLA-1867-1 : wpa security updateNessusDebian Local Security Checks
high
124554Fedora 30 : hostapd (2019-eba1109acd)NessusFedora Local Security Checks
high
124539Fedora 30 : 1:wpa_supplicant (2019-ca49dfd42f)NessusFedora Local Security Checks
high
124252Fedora 29 : hostapd (2019-f409af9fbe)NessusFedora Local Security Checks
high
124250Fedora 28 : hostapd (2019-d03bae77f5)NessusFedora Local Security Checks
high
124219FreeBSD : FreeBSD -- EAP-pwd missing commit validation (2da3cb25-6571-11e9-8e67-206a8a720317)NessusFreeBSD Local Security Checks
high
124038Debian DSA-4430-1 : wpa - security updateNessusDebian Local Security Checks
high
123999Ubuntu 14.04 LTS / 16.04 LTS / 18.04 LTS / 18.10 : wpa_supplicant and hostapd vulnerabilities (USN-3944-1)NessusUbuntu Local Security Checks
high