CVE-2019-9024

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. xmlrpc_decode() can allow a hostile XMLRPC server to cause PHP to read memory outside of allocated areas in base64_decode_xmlrpc in ext/xmlrpc/libxmlrpc/base64.c.

References

http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00083.html

http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html

http://www.securityfocus.com/bid/107156

https://access.redhat.com/errata/RHSA-2019:2519

https://access.redhat.com/errata/RHSA-2019:3299

https://bugs.php.net/bug.php?id=77380

https://security.netapp.com/advisory/ntap-20190321-0001/

https://usn.ubuntu.com/3902-1/

https://usn.ubuntu.com/3902-2/

https://www.debian.org/security/2019/dsa-4398

Details

Source: MITRE

Published: 2019-02-22

Updated: 2019-06-18

Type: CWE-125

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (30 total)

IDNameProductFamilySeverity
145814CentOS 8 : php:7.2 (CESA-2020:1624)NessusCentOS Local Security Checks
critical
143988NewStart CGSL CORE 5.05 / MAIN 5.05 : php Multiple Vulnerabilities (NS-SA-2020-0090)NessusNewStart CGSL Local Security Checks
critical
143917NewStart CGSL CORE 5.04 / MAIN 5.04 : php Multiple Vulnerabilities (NS-SA-2020-0059)NessusNewStart CGSL Local Security Checks
critical
136057RHEL 8 : php:7.2 (RHSA-2020:1624)NessusRed Hat Local Security Checks
critical
135827Scientific Linux Security Update : php on SL7.x x86_64 (20200407)NessusScientific Linux Local Security Checks
critical
135338CentOS 7 : php (CESA-2020:1112)NessusCentOS Local Security Checks
critical
135040RHEL 7 : php (RHSA-2020:1112)NessusRed Hat Local Security Checks
critical
126035openSUSE Security Update : php7 (openSUSE-2019-1573)NessusSuSE Local Security Checks
critical
126034openSUSE Security Update : php7 (openSUSE-2019-1572)NessusSuSE Local Security Checks
critical
125850SUSE SLED15 / SLES15 Security Update : php7 (SUSE-SU-2019:1461-1)NessusSuSE Local Security Checks
critical
124998EulerOS Virtualization 3.0.1.0 : php (EulerOS-SA-2019-1545)NessusHuawei Local Security Checks
critical
124905EulerOS Virtualization for ARM 64 3.0.1.0 : php (EulerOS-SA-2019-1402)NessusHuawei Local Security Checks
critical
124401openSUSE Security Update : php7 (openSUSE-2019-1293)NessusSuSE Local Security Checks
critical
124263openSUSE Security Update : php5 (openSUSE-2019-1256)NessusSuSE Local Security Checks
critical
124190SUSE SLES12 Security Update : php5 (SUSE-SU-2019:0985-1)NessusSuSE Local Security Checks
critical
123826SUSE SLES11 Security Update : php53 (SUSE-SU-2019:14013-1)NessusSuSE Local Security Checks
critical
123732EulerOS Virtualization 2.5.3 : php (EulerOS-SA-2019-1264)NessusHuawei Local Security Checks
critical
123620EulerOS 2.0 SP5 : php (EulerOS-SA-2019-1146)NessusHuawei Local Security Checks
critical
123594EulerOS 2.0 SP2 : php (EulerOS-SA-2019-1120)NessusHuawei Local Security Checks
critical
123113EulerOS 2.0 SP3 : php (EulerOS-SA-2019-1100)NessusHuawei Local Security Checks
critical
98245PHP 5.6.x < 5.6.40 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98244PHP 7.1.x < 7.1.26 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98243PHP 7.2.x < 7.2.14 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98242PHP 7.3.x < 7.3.1 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
122667Ubuntu 14.04 LTS / 16.04 LTS : php5, php7.0 vulnerabilities (USN-3902-1)NessusUbuntu Local Security Checks
critical
122517Debian DSA-4398-1 : php7.0 - security updateNessusDebian Local Security Checks
critical
121602PHP 5.6.x < 5.6.40 Multiple vulnerabilities.NessusCGI abuses
critical
121510PHP 7.1.x < 7.1.26 Multiple vulnerabilities.NessusCGI abuses
critical
121475PHP 7.3.x < 7.3.1 Multiple vulnerabilities.NessusCGI abuses
critical
121353PHP 7.2.x < 7.2.14 Multiple vulnerabilities.NessusCGI abuses
critical