CVE-2019-2766

low
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Networking). Supported versions that are affected are Java SE: 7u221, 8u212, 11.0.3 and 12.0.1; Java SE Embedded: 8u211. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized read access to a subset of Java SE, Java SE Embedded accessible data. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets (in Java SE 8), that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability can also be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. CVSS 3.0 Base Score 3.1 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N).

References

http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00038.html

http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00044.html

http://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html

https://kc.mcafee.com/corporate/index?page=content&id=SB10300

https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst03977en_us

Details

Source: MITRE

Published: 2019-07-23

Updated: 2020-09-08

Risk Information

CVSS v2

Base Score: 2.6

Vector: AV:N/AC:H/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 4.9

Severity: LOW

CVSS v3

Base Score: 3.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N

Impact Score: 1.4

Exploitability Score: 1.6

Severity: LOW

Tenable Plugins

View all (21 total)

IDNameProductFamilySeverity
153359EulerOS 2.0 SP2 : java-1.8.0-openjdk (EulerOS-SA-2021-2389)NessusHuawei Local Security Checks
medium
153075EulerOS 2.0 SP5 : java-1.8.0-openjdk (EulerOS-SA-2021-2335)NessusHuawei Local Security Checks
medium
152291EulerOS 2.0 SP8 : java-1.8.0-openjdk (EulerOS-SA-2021-2300)NessusHuawei Local Security Checks
medium
151215OpenJDK 7 <= 7u221 / 8 <= 8u212 / 11.0.0 <= 11.0.3 / 12.0.0 <= 12.0.1 Multiple Vulnerabilities (2019-07-16)NessusMisc.
medium
150540SUSE SLES11 Security Update : java-1_7_1-ibm (SUSE-SU-2019:14160-1)NessusSuSE Local Security Checks
medium
136333Photon OS 2.0: Openjdk11 PHSA-2020-2.0-0235NessusPhotonOS Local Security Checks
medium
136109Photon OS 1.0: Openjdk11 PHSA-2020-1.0-0290NessusPhotonOS Local Security Checks
critical
136100Photon OS 3.0: Openjdk11 PHSA-2020-3.0-0084NessusPhotonOS Local Security Checks
critical
130102Photon OS 3.0: Openjdk8 PHSA-2019-3.0-0035NessusPhotonOS Local Security Checks
medium
128872SUSE SLES12 Security Update : java-1_8_0-ibm (SUSE-SU-2019:2371-1)NessusSuSE Local Security Checks
critical
128628SUSE SLES12 Security Update : java-1_7_1-ibm (SUSE-SU-2019:2336-1)NessusSuSE Local Security Checks
medium
128520SUSE SLED15 / SLES15 Security Update : java-1_8_0-ibm (SUSE-SU-2019:2291-1)NessusSuSE Local Security Checks
critical
128008openSUSE Security Update : java-11-openjdk (openSUSE-2019-1916)NessusSuSE Local Security Checks
medium
128004openSUSE Security Update : java-1_8_0-openjdk (openSUSE-2019-1912)NessusSuSE Local Security Checks
medium
127762SUSE SLED12 / SLES12 Security Update : java-1_8_0-openjdk (SUSE-SU-2019:2036-1)NessusSuSE Local Security Checks
medium
127758SUSE SLED12 / SLES12 Security Update : java-1_7_0-openjdk (SUSE-SU-2019:2028-1) (Spectre)NessusSuSE Local Security Checks
medium
127757SUSE SLED15 / SLES15 Security Update : java-1_8_0-openjdk (SUSE-SU-2019:2021-1)NessusSuSE Local Security Checks
medium
127745SUSE SLED15 / SLES15 Security Update : java-11-openjdk (SUSE-SU-2019:2002-1)NessusSuSE Local Security Checks
medium
126958Amazon Linux 2 : java-11-amazon-corretto (ALAS-2019-1246)NessusAmazon Linux Local Security Checks
medium
126821Oracle Java SE 1.7.0_231 / 1.8.0_221 / 1.11.0_4 / 1.12.0_2 Multiple Vulnerabilities (Jul 2019 CPU)NessusWindows
medium
126820Oracle Java SE 1.7.0_231 / 1.8.0_221 / 1.11.0_4 / 1.12.0_2 Multiple Vulnerabilities (Jul 2019 CPU) (Unix)NessusMisc.
medium