CVE-2019-20908

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An issue was discovered in drivers/firmware/efi/efi.c in the Linux kernel before 5.4. Incorrect access permissions for the efivar_ssdt ACPI variable could be used by attackers to bypass lockdown or secure boot restrictions, aka CID-1957a85b0032.

References

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=1957a85b0032a81e6482ca4aab883643b8dae06e

https://git.zx2c4.com/american-unsigned-language/tree/american-unsigned-language.sh

https://mailarchives.bentasker.co.uk/Mirrors/OSSSec/2020/06-Jun/msg00035.html

https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.4

http://www.openwall.com/lists/oss-security/2020/07/20/6

https://usn.ubuntu.com/4427-1/

http://www.openwall.com/lists/oss-security/2020/07/29/3

http://www.openwall.com/lists/oss-security/2020/07/30/2

http://www.openwall.com/lists/oss-security/2020/07/30/3

https://usn.ubuntu.com/4439-1/

https://usn.ubuntu.com/4426-1/

https://usn.ubuntu.com/4440-1/

http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00009.html

Details

Source: MITRE

Published: 2020-07-15

Updated: 2021-07-21

Type: CWE-269

Risk Information

CVSS v2

Base Score: 6.9

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.4

Severity: MEDIUM

CVSS v3

Base Score: 6.7

Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 0.8

Severity: MEDIUM

Tenable Plugins

View all (18 total)

IDNameProductFamilySeverity
140378SUSE SLES15 Security Update : kernel (SUSE-SU-2020:2487-1)NessusSuSE Local Security Checks
medium
139476Oracle Linux 7 : Unbreakable Enterprise kernel (ELSA-2020-5804)NessusOracle Linux Local Security Checks
high
139401openSUSE Security Update : the Linux Kernel (openSUSE-2020-1153)NessusSuSE Local Security Checks
critical
139363SUSE SLES12 Security Update : kernel (SUSE-SU-2020:2122-1)NessusSuSE Local Security Checks
critical
139362SUSE SLES12 Security Update : kernel (SUSE-SU-2020:2121-1)NessusSuSE Local Security Checks
critical
139361SUSE SLES12 Security Update : kernel (SUSE-SU-2020:2119-1)NessusSuSE Local Security Checks
critical
139310SUSE SLED15 / SLES15 Security Update : kernel (SUSE-SU-2020:2107-1)NessusSuSE Local Security Checks
critical
139309SUSE SLES15 Security Update : kernel (SUSE-SU-2020:2106-1)NessusSuSE Local Security Checks
critical
139275Oracle Linux 8 : kernel (ELSA-2020-3218)NessusOracle Linux Local Security Checks
medium
139191RHEL 8 : kernel (RHSA-2020:3228)NessusRed Hat Local Security Checks
medium
139188RHEL 8 : kernel (RHSA-2020:3218)NessusRed Hat Local Security Checks
medium
139187RHEL 8 : kernel (RHSA-2020:3222)NessusRed Hat Local Security Checks
medium
139183RHEL 8 : kernel-rt (RHSA-2020:3219)NessusRed Hat Local Security Checks
medium
139166Oracle Linux 7 : Unbreakable Enterprise kernel (ELSA-2020-5791)NessusOracle Linux Local Security Checks
medium
139028Ubuntu 18.04 LTS : linux kernel vulnerabilities (USN-4440-1)NessusUbuntu Local Security Checks
medium
139027Ubuntu 18.04 LTS : Linux kernel vulnerabilities (USN-4439-1)NessusUbuntu Local Security Checks
medium
138836Ubuntu 16.04 LTS : Linux kernel vulnerabilities (USN-4427-1)NessusUbuntu Local Security Checks
high
138835Ubuntu 16.04 LTS / 18.04 LTS : Linux kernel vulnerabilities (USN-4426-1)NessusUbuntu Local Security Checks
medium