CVE-2019-19012

critical

Description

An integer overflow in the search_in_range function in regexec.c in Oniguruma 6.x before 6.9.4_rc2 leads to an out-of-bounds read, in which the offset of this read is under the control of an attacker. (This only affects the 32-bit compiled version). Remote attackers can cause a denial-of-service or information disclosure, or possibly have unspecified other impact, via a crafted regular expression.

References

https://github.com/kkos/oniguruma/issues/164

https://github.com/kkos/oniguruma/releases/tag/v6.9.4_rc2

https://github.com/tarantula-team/CVE-2019-19012

https://lists.debian.org/debian-lts-announce/2019/12/msg00002.html

https://lists.fedoraproject.org/archives/list/[email protected]/message/NO267PLHGYZSWX3XTRPKYBKD4J3YOU5V/

https://lists.fedoraproject.org/archives/list/[email protected]/message/V3MBNW6Z4DOXSCNWGBLQ7OA3OGUJ44WL/

https://usn.ubuntu.com/4460-1/

Details

Source: MITRE

Published: 2019-11-17

Updated: 2020-08-24

Type: CWE-190

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL