CVE-2019-17361

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In SaltStack Salt through 2019.2.0, the salt-api NET API with the ssh client enabled is vulnerable to command injection. This allows an unauthenticated attacker with network access to the API endpoint to execute arbitrary code on the salt-api host.

References

http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00026.html

https://docs.saltstack.com/en/latest/topics/releases/2019.2.3.html#security-fix

https://github.com/saltstack/salt/commits/master

https://usn.ubuntu.com/4459-1/

https://www.debian.org/security/2020/dsa-4676

Details

Source: MITRE

Published: 2020-01-17

Updated: 2020-08-24

Type: CWE-77

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 9.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
139659Ubuntu 16.04 LTS / 18.04 LTS : Salt vulnerabilities (USN-4459-1)NessusUbuntu Local Security Checks
critical
136372Debian DSA-4676-1 : salt - security updateNessusDebian Local Security Checks
critical
134696openSUSE Security Update : salt (openSUSE-2020-357)NessusSuSE Local Security Checks
high
134622SUSE SLED15 / SLES15 Security Update : salt (SUSE-SU-2020:0684-1)NessusSuSE Local Security Checks
high
134336FreeBSD : salt -- salt-api vulnerability (8c98e643-6008-11ea-af63-38d547003487)NessusFreeBSD Local Security Checks
critical