CVE-2019-17008

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

When using nested workers, a use-after-free could occur during worker destruction. This resulted in a potentially exploitable crash. This vulnerability affects Thunderbird < 68.3, Firefox ESR < 68.3, and Firefox < 71.

References

http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00000.html

http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00001.html

https://bugzilla.mozilla.org/show_bug.cgi?id=1546331

https://usn.ubuntu.com/4241-1/

https://www.mozilla.org/security/advisories/mfsa2019-36/

https://www.mozilla.org/security/advisories/mfsa2019-37/

https://www.mozilla.org/security/advisories/mfsa2019-38/

Details

Source: MITRE

Published: 2020-01-08

Updated: 2020-01-16

Type: CWE-416

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (52 total)

IDNameProductFamilySeverity
150601SUSE SLES11 Security Update : MozillaFirefox, mozilla-nspr, mozilla-nss (SUSE-SU-2019:14260-1)NessusSuSE Local Security Checks
high
147407NewStart CGSL MAIN 4.06 : firefox Multiple Vulnerabilities (NS-SA-2021-0004)NessusNewStart CGSL Local Security Checks
critical
147312NewStart CGSL MAIN 4.06 : thunderbird Multiple Vulnerabilities (NS-SA-2021-0002)NessusNewStart CGSL Local Security Checks
critical
145636CentOS 8 : thunderbird (CESA-2019:4195)NessusCentOS Local Security Checks
high
145585CentOS 8 : firefox (CESA-2019:4111)NessusCentOS Local Security Checks
high
135896Ubuntu 16.04 LTS : Thunderbird vulnerabilities (USN-4335-1)NessusUbuntu Local Security Checks
critical
134587GLSA-202003-10 : Mozilla Thunderbird: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
134469GLSA-202003-02 : Mozilla Firefox: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
134411NewStart CGSL MAIN 4.05 : firefox Multiple Vulnerabilities (NS-SA-2020-0017)NessusNewStart CGSL Local Security Checks
critical
134410NewStart CGSL MAIN 4.05 : thunderbird Multiple Vulnerabilities (NS-SA-2020-0022)NessusNewStart CGSL Local Security Checks
critical
133386RHEL 8 : firefox (RHSA-2020:0295)NessusRed Hat Local Security Checks
high
133384RHEL 8 : thunderbird (RHSA-2020:0292)NessusRed Hat Local Security Checks
high
133149Amazon Linux 2 : thunderbird (ALAS-2020-1386)NessusAmazon Linux Local Security Checks
high
133080NewStart CGSL CORE 5.05 / MAIN 5.05 : firefox Multiple Vulnerabilities (NS-SA-2020-0004)NessusNewStart CGSL Local Security Checks
high
133071NewStart CGSL CORE 5.05 / MAIN 5.05 : thunderbird Multiple Vulnerabilities (NS-SA-2020-0003)NessusNewStart CGSL Local Security Checks
high
133040Ubuntu 18.04 LTS / 19.10 : Thunderbird vulnerabilities (USN-4241-1)NessusUbuntu Local Security Checks
high
132764openSUSE Security Update : MozillaThunderbird (openSUSE-2020-3)NessusSuSE Local Security Checks
high
132763openSUSE Security Update : MozillaFirefox (openSUSE-2020-2)NessusSuSE Local Security Checks
high
132482NewStart CGSL CORE 5.04 / MAIN 5.04 : thunderbird Multiple Vulnerabilities (NS-SA-2019-0265)NessusNewStart CGSL Local Security Checks
high
132438NewStart CGSL CORE 5.04 / MAIN 5.04 : firefox Multiple Vulnerabilities (NS-SA-2019-0261)NessusNewStart CGSL Local Security Checks
high
132401CentOS 6 : thunderbird (CESA-2019:4205)NessusCentOS Local Security Checks
high
132399CentOS 7 : thunderbird (CESA-2019:4148)NessusCentOS Local Security Checks
high
132398CentOS 7 : firefox (CESA-2019:4107)NessusCentOS Local Security Checks
high
132336SUSE SLED12 / SLES12 Security Update : MozillaFirefox (SUSE-SU-2019:3347-1)NessusSuSE Local Security Checks
high
132308SUSE SLED15 / SLES15 Security Update : MozillaFirefox (SUSE-SU-2019:3337-1)NessusSuSE Local Security Checks
high
132082Debian DSA-4585-1 : thunderbird - security updateNessusDebian Local Security Checks
high
132080Debian DLA-2036-1 : thunderbird security updateNessusDebian Local Security Checks
high
131990Scientific Linux Security Update : thunderbird on SL6.x i386/x86_64 (20191211)NessusScientific Linux Local Security Checks
high
131989Scientific Linux Security Update : thunderbird on SL7.x x86_64 (20191210)NessusScientific Linux Local Security Checks
high
131986RHEL 6 : thunderbird (RHSA-2019:4205)NessusRed Hat Local Security Checks
high
131985RHEL 8 : thunderbird (RHSA-2019:4195)NessusRed Hat Local Security Checks
high
131977RHEL 7 : thunderbird (RHSA-2019:4148)NessusRed Hat Local Security Checks
high
131974Oracle Linux 8 : thunderbird (ELSA-2019-4195)NessusOracle Linux Local Security Checks
high
131971Oracle Linux 7 : thunderbird (ELSA-2019-4148)NessusOracle Linux Local Security Checks
high
131962Debian DLA-2029-1 : firefox-esr security updateNessusDebian Local Security Checks
high
131958CentOS 6 : firefox (CESA-2019:4108)NessusCentOS Local Security Checks
high
131956Mozilla Thunderbird < 68.3NessusWindows
high
131955Mozilla Thunderbird < 68.3NessusMacOS X Local Security Checks
high
131924Ubuntu 18.04 LTS / 19.04 / 19.10 : firefox vulnerabilities (USN-4216-1)NessusUbuntu Local Security Checks
high
131838Debian DSA-4580-1 : firefox-esr - security updateNessusDebian Local Security Checks
high
131831Scientific Linux Security Update : firefox on SL7.x x86_64 (20191205)NessusScientific Linux Local Security Checks
high
131830Scientific Linux Security Update : firefox on SL6.x i386/x86_64 (20191205)NessusScientific Linux Local Security Checks
high
131829Oracle Linux 8 : firefox (ELSA-2019-4111)NessusOracle Linux Local Security Checks
high
131828Oracle Linux 7 : firefox (ELSA-2019-4107)NessusOracle Linux Local Security Checks
high
131773Mozilla Firefox < 71.0NessusWindows
high
131772Mozilla Firefox < 71.0NessusMacOS X Local Security Checks
high
131767Mozilla Firefox ESR 68.x < 68.3 Multiple vulnerabilitiesNessusWindows
high
131766Mozilla Firefox ESR 68.x < 68.3 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
131749RHEL 8 : firefox (RHSA-2019:4111)NessusRed Hat Local Security Checks
high
131746RHEL 6 : firefox (RHSA-2019:4108)NessusRed Hat Local Security Checks
high
131745RHEL 7 : firefox (RHSA-2019:4107)NessusRed Hat Local Security Checks
high
131681Slackware 14.2 / current : mozilla-firefox (SSA:2019-337-01)NessusSlackware Local Security Checks
high