CVE-2019-16777

MEDIUM

Description

Versions of the npm CLI prior to 6.13.4 are vulnerable to an Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a serve binary, any subsequent installs of packages that also create a serve binary would overwrite the previous serve binary. This behavior is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.

References

http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00027.html

https://access.redhat.com/errata/RHEA-2020:0330

https://access.redhat.com/errata/RHSA-2020:0573

https://access.redhat.com/errata/RHSA-2020:0579

https://access.redhat.com/errata/RHSA-2020:0597

https://access.redhat.com/errata/RHSA-2020:0602

https://blog.npmjs.org/post/189618601100/binary-planting-with-the-npm-cli

https://github.com/npm/cli/security/advisories/GHSA-4328-8hgf-7wjr

https://lists.fedoraproject.org/archives/list/[email protected]/message/Z36UKPO5F3PQ3Q2POMF5LEKXWAH5RUFP/

https://security.gentoo.org/glsa/202003-48

https://www.oracle.com/security-alerts/cpujan2020.html

Details

Source: MITRE

Published: 2019-12-13

Updated: 2020-10-09

Type: CWE-269

Risk Information

CVSS v2.0

Base Score: 5.5

Vector: AV:N/AC:L/Au:S/C:N/I:P/A:P

Impact Score: 4.9

Exploitability Score: 8

Severity: MEDIUM

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM