CVE-2019-15925

HIGH

Description

An issue was discovered in the Linux kernel before 5.2.3. An out of bounds access exists in the function hclge_tm_schd_mode_vnet_base_cfg in the file drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_tm.c.

References

https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2.3

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=04f25edb48c441fc278ecc154c270f16966cbb90

https://security.netapp.com/advisory/ntap-20191004-0001/

https://usn.ubuntu.com/4147-1/

Details

Source: MITRE

Published: 2019-09-04

Updated: 2019-10-04

Type: CWE-125

Risk Information

CVSS v2.0

Base Score: 7.2

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.9

Severity: HIGH

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
145806CentOS 8 : kernel (CESA-2020:4431)NessusCentOS Local Security Checks
high
142430RHEL 8 : kernel (RHSA-2020:4431)NessusRed Hat Local Security Checks
high
142382RHEL 8 : kernel-rt (RHSA-2020:4609)NessusRed Hat Local Security Checks
high
134387EulerOS 2.0 SP8 : kernel (EulerOS-SA-2020-1186)NessusHuawei Local Security Checks
critical
129677Ubuntu 18.04 LTS / 19.04 : linux, linux-aws, linux-azure, linux-gcp, linux-gke-5.0, linux-hwe, (USN-4147-1)NessusUbuntu Local Security Checks
high
128732Photon OS 3.0: Linux PHSA-2019-3.0-0026NessusPhotonOS Local Security Checks
high