CVE-2019-15791

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In shiftfs, a non-upstream patch to the Linux kernel included in the Ubuntu 5.0 and 5.3 kernel series, shiftfs_btrfs_ioctl_fd_replace() installs an fd referencing a file from the lower filesystem without taking an additional reference to that file. After the btrfs ioctl completes this fd is closed, which then puts a reference to that file, leading to a refcount underflow.

References

https://git.launchpad.net/~ubuntu-kernel/ubuntu/+source/linux/+git/eoan/commit/?id=601a64857b3d7040ca15c39c929e6b9db3373ec1

https://usn.ubuntu.com/usn/usn-4183-1

https://usn.ubuntu.com/usn/usn-4184-1

Details

Source: MITRE

Published: 2020-04-24

Updated: 2020-05-01

Type: CWE-191

Risk Information

CVSS v2

Base Score: 4.6

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 3.9

Severity: MEDIUM

CVSS v3

Base Score: 7.8

Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
131012Ubuntu 18.04 LTS / 19.04 : Linux kernel vulnerability and regression (USN-4184-2)NessusUbuntu Local Security Checks
high
131011Ubuntu 19.10 : Linux kernel vulnerability (USN-4183-2)NessusUbuntu Local Security Checks
high
130964Ubuntu 18.04 LTS / 19.04 : Linux kernel vulnerabilities (USN-4184-1)NessusUbuntu Local Security Checks
high
130963Ubuntu 19.10 : Linux kernel vulnerabilities (USN-4183-1)NessusUbuntu Local Security Checks
high