CVE-2019-15694

high

Description

TigerVNC version prior to 1.10.1 is vulnerable to heap buffer overflow, which could be triggered from DecodeManager::decodeRect. Vulnerability occurs due to the signdness error in processing MemOutStream. Exploitation of this vulnerability could potentially result into remote code execution. This attack appear to be exploitable via network connectivity.

References

http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00039.html

https://github.com/CendioOssman/tigervnc/commit/0943c006c7d900dfc0281639e992791d6c567438

https://github.com/TigerVNC/tigervnc/releases/tag/v1.10.1

https://www.openwall.com/lists/oss-security/2019/12/20/2

Details

Source: MITRE

Published: 2019-12-26

Updated: 2020-10-16

Type: CWE-787

Risk Information

CVSS v2

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

CVSS v3

Base Score: 7.2

Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.2

Severity: HIGH