CVE-2019-14869

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A flaw was found in all versions of ghostscript 9.x before 9.50, where the `.charkeys` procedure, where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges within the Ghostscript and access files outside of restricted areas or execute commands.

References

http://jvn.jp/en/jp/JVN52486659/index.html

http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00049.html

http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00050.html

http://www.openwall.com/lists/oss-security/2019/11/15/1

https://access.redhat.com/errata/RHSA-2020:0222

https://bugs.ghostscript.com/show_bug.cgi?id=701841

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14869

https://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=485904772c5f

https://lists.fedoraproject.org/archives/list/[email protected]/message/2Q4E3OTDAJRSUCOBTDQO7Y5UTE2FFMLF/

https://lists.fedoraproject.org/archives/list/[email protected]/message/HC4REO73BEJOJAU7NHFHJECAUAYJUE3H/

https://lists.fedoraproject.org/archives/list/[email protected]/message/IX55AEDERTDFEZAROKZW64MZRPLINEGI/

https://seclists.org/bugtraq/2019/Nov/27

Details

Source: MITRE

Published: 2019-11-15

Updated: 2020-10-09

Type: CWE-732

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (24 total)

IDNameProductFamilySeverity
146633Amazon Linux 2 : ghostscript (ALAS-2021-1598)NessusAmazon Linux Local Security Checks
critical
145677CentOS 8 : ghostscript (CESA-2019:3890)NessusCentOS Local Security Checks
high
144019Virtuozzo 7 : ghostscript / ghostscript-cups / ghostscript-doc / etc (VZLSA-2019-3888)NessusVirtuozzo Local Security Checks
high
133223RHEL 8 : ghostscript (RHSA-2020:0222)NessusRed Hat Local Security Checks
high
133083NewStart CGSL CORE 5.05 / MAIN 5.05 : ghostscript Vulnerability (NS-SA-2020-0007)NessusNewStart CGSL Local Security Checks
high
132813EulerOS Virtualization for ARM 64 3.0.5.0 : ghostscript (EulerOS-SA-2020-1059)NessusHuawei Local Security Checks
high
132599EulerOS 2.0 SP8 : ghostscript (EulerOS-SA-2020-1006)NessusHuawei Local Security Checks
high
132481NewStart CGSL CORE 5.04 / MAIN 5.04 : ghostscript Vulnerability (NS-SA-2019-0265)NessusNewStart CGSL Local Security Checks
high
131569CentOS 7 : ghostscript (CESA-2019:3888)NessusCentOS Local Security Checks
high
131274Oracle Linux 8 : ghostscript (ELSA-2019-3890)NessusOracle Linux Local Security Checks
high
131256Fedora 29 : ghostscript (2019-7debdd1807)NessusFedora Local Security Checks
high
131180openSUSE Security Update : ghostscript (openSUSE-2019-2535)NessusSuSE Local Security Checks
high
131179openSUSE Security Update : ghostscript (openSUSE-2019-2534)NessusSuSE Local Security Checks
high
131119SUSE SLED12 / SLES12 Security Update : ghostscript (SUSE-SU-2019:2983-1)NessusSuSE Local Security Checks
high
131118SUSE SLED15 / SLES15 Security Update : ghostscript (SUSE-SU-2019:2981-1)NessusSuSE Local Security Checks
high
131113Oracle Linux 7 : ghostscript (ELSA-2019-3888)NessusOracle Linux Local Security Checks
high
131094Fedora 31 : ghostscript (2019-6cdb10aa59)NessusFedora Local Security Checks
high
131089Fedora 30 : ghostscript (2019-17f42f585a)NessusFedora Local Security Checks
high
131073Ubuntu 16.04 LTS / 18.04 LTS / 19.04 / 19.10 : Ghostscript vulnerability (USN-4193-1)NessusUbuntu Local Security Checks
high
131054Scientific Linux Security Update : ghostscript on SL7.x x86_64 (20191114)NessusScientific Linux Local Security Checks
high
131053RHEL 8 : ghostscript (RHSA-2019:3890)NessusRed Hat Local Security Checks
high
131051RHEL 7 : ghostscript (RHSA-2019:3888)NessusRed Hat Local Security Checks
high
131036Debian DSA-4569-1 : ghostscript - security updateNessusDebian Local Security Checks
high
131035Debian DLA-1992-1 : ghostscript security updateNessusDebian Local Security Checks
high