CVE-2019-14834

low

Description

A vulnerability was found in dnsmasq before version 2.81, where the memory leak allows remote attackers to cause a denial of service (memory consumption) via vectors involving DHCP response creation.

References

http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=69bc94779c2f035a9fffdb5327a54c3aeca73ed5

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14834

https://lists.fedoraproject.org/archives/list/[email protected]/message/JU474LT66BHNVFG5C4GEV3VTZNAEJ3BS/

Details

Source: MITRE

Published: 2020-01-07

Updated: 2020-12-04

Type: CWE-770

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 3.7

Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Impact Score: 1.4

Exploitability Score: 2.2

Severity: LOW