CVE-2019-12984

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A NULL pointer dereference vulnerability in the function nfc_genl_deactivate_target() in net/nfc/netlink.c in the Linux kernel before 5.1.13 can be triggered by a malicious user-mode program that omits certain NFC attributes, leading to denial of service.

References

http://packetstormsecurity.com/files/154245/Kernel-Live-Patch-Security-Notice-LSN-0054-1.html

http://www.securityfocus.com/bid/108905

https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.1.13

https://github.com/torvalds/linux/commit/385097a3675749cbc9e97c085c0e5dfe4269ca51

https://seclists.org/bugtraq/2019/Aug/13

https://security.netapp.com/advisory/ntap-20190806-0001/

https://usn.ubuntu.com/4093-1/

https://usn.ubuntu.com/4094-1/

https://usn.ubuntu.com/4117-1/

https://usn.ubuntu.com/4118-1/

https://www.debian.org/security/2019/dsa-4495

Details

Source: MITRE

Published: 2019-06-26

Updated: 2019-08-06

Type: CWE-476

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
128929EulerOS Virtualization for ARM 64 3.0.2.0 : kernel (EulerOS-SA-2019-1926)NessusHuawei Local Security Checks
critical
128478Ubuntu 16.04 LTS / 18.04 LTS : linux-aws vulnerabilities (USN-4118-1)NessusUbuntu Local Security Checks
critical
128477Ubuntu 19.04 : linux-aws vulnerabilities (USN-4117-1)NessusUbuntu Local Security Checks
high
127889Ubuntu 16.04 LTS / 18.04 LTS : Linux kernel vulnerabilities (USN-4094-1)NessusUbuntu Local Security Checks
high
127888Ubuntu 18.04 LTS / 19.04 : Linux kernel vulnerabilities (USN-4093-1)NessusUbuntu Local Security Checks
high
127491Debian DSA-4495-1 : linux - security updateNessusDebian Local Security Checks
high