CVE-2019-12838

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

SchedMD Slurm 17.11.x, 18.08.0 through 18.08.7, and 19.05.0 allows SQL Injection.

References

http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00005.html

https://lists.fedoraproject.org/archives/list/[email protected]/message/2O47F72FWMYLEGF35QGNYY5VS33SUQS5/

https://lists.fedoraproject.org/archives/list/[email protected]/message/AQ6EV3OWKGMTBWCSXZGS4MYADUBLVXSQ/

https://lists.schedmd.com/pipermail/slurm-announce/2019/

https://lists.schedmd.com/pipermail/slurm-announce/2019/000025.html

https://www.schedmd.com/news.php

https://www.schedmd.com/news.php?id=218

Details

Source: MITRE

Published: 2019-07-11

Updated: 2019-07-24

Type: CWE-89

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:schedmd:slurm:*:*:*:*:*:*:*:* versions up to 17.11.13.2 (inclusive)

cpe:2.3:a:schedmd:slurm:*:*:*:*:*:*:*:* versions up to 18.08.7 (inclusive)

cpe:2.3:a:schedmd:slurm:19.05.0:*:*:*:*:*:*:*

Tenable Plugins

View all (16 total)

IDNameProductFamilySeverity
156773Debian DLA-2886-1 : slurm-llnl - LTS security updateNessusDebian Local Security Checks
critical
147801SUSE SLES12 Security Update : slurm_20_11 / pdsh (SUSE-SU-2021:0773-1)NessusSuSE Local Security Checks
high
143870SUSE SLES12 Security Update : pdsh, slurm_20_02 (SUSE-SU-2020:2607-1)NessusSuSE Local Security Checks
high
134630Debian DLA-2143-1 : slurm-llnl security updateNessusDebian Local Security Checks
critical
134036SUSE SLED15 / SLES15 Security Update : pdsh, slurm_18_08 (SUSE-SU-2020:0443-1)NessusSuSE Local Security Checks
high
133949SUSE SLES12 Security Update : pdsh, slurm_18_08 (SUSE-SU-2020:0434-1)NessusSuSE Local Security Checks
high
133171openSUSE Security Update : slurm (openSUSE-2020-85)NessusSuSE Local Security Checks
critical
133032SUSE SLED15 / SLES15 Security Update : slurm (SUSE-SU-2020:0110-1)NessusSuSE Local Security Checks
critical
131391SUSE SLES12 Security Update : slurm (SUSE-SU-2019:3080-1)NessusSuSE Local Security Checks
critical
131181openSUSE Security Update : slurm (openSUSE-2019-2536)NessusSuSE Local Security Checks
critical
131140Debian DSA-4572-1 : slurm-llnl - security updateNessusDebian Local Security Checks
critical
131124SUSE SLED15 / SLES15 Security Update : slurm (SUSE-SU-2019:2989-1)NessusSuSE Local Security Checks
critical
128461openSUSE Security Update : slurm (openSUSE-2019-2052)NessusSuSE Local Security Checks
critical
128314SUSE SLED15 / SLES15 Security Update : slurm (SUSE-SU-2019:2229-1)NessusSuSE Local Security Checks
critical
126970Fedora 30 : slurm (2019-5d0d2619df)NessusFedora Local Security Checks
critical
126969Fedora 29 : slurm (2019-4ca3a39825)NessusFedora Local Security Checks
critical