CVE-2019-11719

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

When importing a curve25519 private key in PKCS#8format with leading 0x00 bytes, it is possible to trigger an out-of-bounds read in the Network Security Services (NSS) library. This could lead to information disclosure. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.

References

http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00055.html

http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00058.html

http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00073.html

http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00009.html

http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00010.html

https://access.redhat.com/errata/RHSA-2019:1951

https://bugzilla.mozilla.org/show_bug.cgi?id=1540541

https://lists.debian.org/debian-lts-announce/2020/09/msg00029.html

https://security.gentoo.org/glsa/201908-12

https://security.gentoo.org/glsa/201908-20

https://www.mozilla.org/security/advisories/mfsa2019-21/

https://www.mozilla.org/security/advisories/mfsa2019-22/

https://www.mozilla.org/security/advisories/mfsa2019-23/

Details

Source: MITRE

Published: 2019-07-23

Updated: 2020-09-30

Type: CWE-125

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (37 total)

IDNameProductFamilySeverity
150682SUSE SLES11 Security Update : MozillaFirefox (SUSE-SU-2019:14124-1)NessusSuSE Local Security Checks
critical
147361NewStart CGSL CORE 5.04 / MAIN 5.04 : nss Multiple Vulnerabilities (NS-SA-2021-0019)NessusNewStart CGSL Local Security Checks
critical
145690CentOS 8 : nss and nspr (CESA-2019:1951)NessusCentOS Local Security Checks
medium
142720Amazon Linux 2 : nspr (ALAS-2020-1559)NessusAmazon Linux Local Security Checks
critical
142600CentOS 7 : nss and nspr (CESA-2020:4076)NessusCentOS Local Security Checks
critical
141689Scientific Linux Security Update : nss and nspr on SL7.x x86_64 (20201001)NessusScientific Linux Local Security Checks
critical
141312Oracle Linux 7 : nss / and / nspr (ELSA-2020-4076)NessusOracle Linux Local Security Checks
critical
141062Debian DLA-2388-1 : nss security updateNessusDebian Local Security Checks
critical
141059RHEL 7 : nss and nspr (RHSA-2020:4076)NessusRed Hat Local Security Checks
critical
129772SUSE SLED12 / SLES12 Security Update : MozillaFirefox (SUSE-SU-2019:2620-1)NessusSuSE Local Security Checks
high
129663openSUSE Security Update : MozillaThunderbird (openSUSE-2019-2249)NessusSuSE Local Security Checks
high
129662openSUSE Security Update : MozillaThunderbird (openSUSE-2019-2248)NessusSuSE Local Security Checks
high
128970Mozilla Thunderbird < 68.0NessusWindows
high
128969Mozilla Thunderbird < 68.0NessusMacOS X Local Security Checks
high
127969GLSA-201908-20 : Mozilla Thunderbird: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
127961GLSA-201908-12 : Mozilla Firefox: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
127733openSUSE Security Update : MozillaThunderbird (openSUSE-2019-1813)NessusSuSE Local Security Checks
critical
127731openSUSE Security Update : MozillaFirefox (openSUSE-2019-1811)NessusSuSE Local Security Checks
critical
127636RHEL 8 : nss and nspr (RHSA-2019:1951)NessusRed Hat Local Security Checks
medium
127609Oracle Linux 8 : nspr / nss (ELSA-2019-1951)NessusOracle Linux Local Security Checks
medium
127093Ubuntu 16.04 LTS / 18.04 LTS / 19.04 : Firefox regressions (USN-4054-2)NessusUbuntu Local Security Checks
high
126912openSUSE Security Update : MozillaFirefox (openSUSE-2019-1782)NessusSuSE Local Security Checks
critical
126834Debian DLA-1857-1 : nss security updateNessusDebian Local Security Checks
high
126816Ubuntu 16.04 LTS / 18.04 LTS / 18.10 / 19.04 : Thunderbird vulnerabilities (USN-4064-1)NessusUbuntu Local Security Checks
critical
126810SUSE SLED15 / SLES15 Security Update : MozillaFirefox (SUSE-SU-2019:1869-1)NessusSuSE Local Security Checks
critical
126808SUSE SLED12 / SLES12 Security Update : MozillaFirefox (SUSE-SU-2019:1861-1)NessusSuSE Local Security Checks
critical
126772Ubuntu 16.04 LTS / 18.04 LTS / 19.04 : NSS vulnerabilities (USN-4060-1)NessusUbuntu Local Security Checks
medium
126704Mozilla Thunderbird < 60.8NessusWindows
critical
126703Mozilla Thunderbird < 60.8NessusMacOS X Local Security Checks
critical
126698Ubuntu 16.04 LTS / 18.04 LTS / 18.10 / 19.04 : Firefox vulnerabilities (USN-4054-1)NessusUbuntu Local Security Checks
high
126654Debian DSA-4479-1 : firefox-esr - security updateNessusDebian Local Security Checks
critical
126624Mozilla Firefox ESR < 60.8NessusWindows
critical
126623Mozilla Firefox ESR < 60.8NessusMacOS X Local Security Checks
critical
126622Mozilla Firefox < 68.0NessusWindows
high
126621Mozilla Firefox < 68.0NessusMacOS X Local Security Checks
high
126614Slackware 14.2 / current : mozilla-firefox (SSA:2019-191-01)NessusSlackware Local Security Checks
critical
126592FreeBSD : mozilla -- multiple vulnerabilities (0592f49f-b3b8-4260-b648-d1718762656c)NessusFreeBSD Local Security Checks
high