CVE-2019-11044

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In PHP versions 7.2.x below 7.2.26, 7.3.x below 7.3.13 and 7.4.0 on Windows, PHP link() function accepts filenames with embedded \0 byte and treats them as terminating at that byte. This could lead to security vulnerabilities, e.g. in applications checking paths that the code is allowed to access.

References

https://bugs.php.net/bug.php?id=78862

https://security.netapp.com/advisory/ntap-20200103-0002/

https://lists.fedoraproject.org/archives/list/[email protected]/message/N7GCOAE6KVHYJ3UQ4KLPLTGSLX6IRVRN/

https://lists.fedoraproject.org/archives/list/[email protected]/message/XWRQPYXVG43Q7DXMXH6UVWMKWGUW552F/

Details

Source: MITRE

Published: 2019-12-23

Updated: 2021-07-22

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions from 7.2.0 to 7.2.26 (inclusive)

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions from 7.3.0 to 7.3.13 (inclusive)

cpe:2.3:a:php:php:7.4.0:*:*:*:*:*:*:*

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
152986Tenable SecurityCenter < 5.19.0 Multiple Vulnerabilities (TNS-2021-14)NessusMisc.
high
151985Tenable.sc < 5.19.0 Multiple Vulnerabilities (TNS-2021-14) (deprecated)NessusMisc.
high
133558Amazon Linux AMI : php72 / php73 (ALAS-2020-1339)NessusAmazon Linux Local Security Checks
critical
98927PHP 7.2.x < 7.2.26 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98926PHP 7.3.x < 7.3.13 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98925PHP 7.4.x < 7.4.1 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
132770PHP 7.2.x < 7.2.26 Multiple VulnerabilitiesNessusCGI abuses
medium
132769PHP 7.3.x < 7.3.13 / 7.4.x < 7.4.1 Multiple VulnerabilitiesNessusCGI abuses
critical
132655Fedora 31 : php (2019-a54a622670)NessusFedora Local Security Checks
critical
132644Fedora 30 : php (2019-437d94e271)NessusFedora Local Security Checks
critical