CVE-2018-9846

MEDIUM

Description

In Roundcube from versions 1.2.0 to 1.3.5, with the archive plugin enabled and configured, it's possible to exploit the unsanitized, user-controlled "_uid" parameter (in an archive.php _task=mail&_mbox=INBOX&_action=plugin.move2archive request) to perform an MX (IMAP) injection attack by placing an IMAP command after a %0d%0a sequence. NOTE: this is less easily exploitable in 1.3.4 and later because of a Same Origin Policy protection mechanism.

References

https://github.com/roundcube/roundcubemail/issues/6229

https://github.com/roundcube/roundcubemail/issues/6238

https://medium.com/@ndrbasi/cve-2018-9846-roundcube-303097048b0a

https://www.debian.org/security/2018/dsa-4181

Details

Source: MITRE

Published: 2018-04-07

Updated: 2018-05-24

Type: CWE-20

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:roundcube:webmail:*:*:*:*:*:*:*:* versions from 1.2.0 to 1.3.5 (inclusive)

Configuration 2

OR

cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
120762Fedora 28 : roundcubemail (2018-c279b3696f)NessusFedora Local Security Checks
medium
109410Debian DSA-4181-1 : roundcube - security updateNessusDebian Local Security Checks
medium
109227Fedora 26 : roundcubemail (2018-f6dc921a19)NessusFedora Local Security Checks
medium
109222Fedora 27 : roundcubemail (2018-57fbdb1cb5)NessusFedora Local Security Checks
medium
109052FreeBSD : roundcube -- IMAP command injection vulnerability (48894ca9-3e6f-11e8-92f0-f0def167eeea)NessusFreeBSD Local Security Checks
medium