CVE-2018-7685

MEDIUM

Description

The decoupled download and installation steps in libzypp before 17.5.0 could lead to a corrupted RPM being left in the cache, where a later call would not display the corrupted RPM warning and allow installation, a problem caused by malicious warnings only displayed during download.

References

http://lists.suse.com/pipermail/sle-security-updates/2018-August/004510.html

https://bugzilla.suse.com/show_bug.cgi?id=1091624

https://www.suse.com/de-de/security/cve/CVE-2018-7685/

Details

Source: MITRE

Published: 2018-08-31

Updated: 2018-11-08

Type: CWE-284

Risk Information

CVSS v2.0

Base Score: 4.6

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 3.9

Severity: MEDIUM

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH