CVE-2018-6574

MEDIUM

Description

Go before 1.8.7, Go 1.9.x before 1.9.4, and Go 1.10 pre-releases before Go 1.10rc2 allow "go get" remote command execution during source code build, by leveraging the gcc or clang plugin feature, because -fplugin= and -plugin= arguments were not blocked.

References

https://access.redhat.com/errata/RHSA-2018:0878

https://access.redhat.com/errata/RHSA-2018:1304

https://github.com/golang/go/issues/23672

https://github.com/KINGSABRI/CVE-in-Ruby/tree/master/CVE-2018-6574

https://groups.google.com/forum/#!topic/golang-nuts/Gbhh1NxAjMU

https://groups.google.com/forum/#!topic/golang-nuts/sprOaQ5m3Dk

https://www.debian.org/security/2019/dsa-4380

Details

Source: MITRE

Published: 2018-02-07

Updated: 2019-03-01

Type: CWE-284

Risk Information

CVSS v2.0

Base Score: 4.6

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 3.9

Severity: MEDIUM

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH