CVE-2018-21031

MEDIUM

Description

Tautulli versions 2.1.38 and below allows remote attackers to bypass intended access control in Plex Media Server because the X-Plex-Token is mishandled and can be retrieved from Tautulli. NOTE: Initially, this id was associated with Plex Media Server 1.18.2.2029-36236cc4c as the affected product and version. Further research indicated that Tautulli is the correct affected product.

References

https://forums.plex.tv/t/security-regarding-cve-2018-21031/493286

https://twitter.com/GerardFuguet/status/1009937529573912576

https://www.elladodelmal.com/2018/08/shodan-es-de-cine-hacking-tautulli-un.html

Details

Source: MITRE

Published: 2019-11-18

Updated: 2019-12-03

Type: CWE-522

Risk Information

CVSS v2.0

Base Score: 4

Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 8

Severity: MEDIUM

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM