CVE-2018-19296

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

PHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack.

References

https://github.com/PHPMailer/PHPMailer/releases/tag/v6.0.6

https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.27

https://www.debian.org/security/2018/dsa-4351

https://lists.debian.org/debian-lts-announce/2018/12/msg00020.html

https://lists.fedoraproject.org/archives/list/[email protected]/message/KPU66INRFY5BQ3ESVPRUXJR4DXQAFJVT/

https://lists.fedoraproject.org/archives/list/[email protected]/message/3B5WDPGUFNPG4NAZ6G4BZX43BKLAVA5B/

Details

Source: MITRE

Published: 2018-11-16

Updated: 2021-05-21

Type: CWE-502

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (31 total)

IDNameProductFamilySeverity
152214Debian DLA-2731-1 : wordpress - LTS security updateNessusDebian Local Security Checks
critical
112793WordPress 5.7.x < 5.7.2 Object injectionWeb Application ScanningComponent Vulnerability
critical
112792WordPress 5.6.x < 5.6.4 Object injectionWeb Application ScanningComponent Vulnerability
critical
112791WordPress 5.5.x < 5.5.5 Object injectionWeb Application ScanningComponent Vulnerability
critical
112790WordPress 5.4.x < 5.4.6 Object injectionWeb Application ScanningComponent Vulnerability
critical
112789WordPress 5.3.x < 5.3.8 Object injectionWeb Application ScanningComponent Vulnerability
critical
112788WordPress 5.2.x < 5.2.11 Object injectionWeb Application ScanningComponent Vulnerability
critical
112787WordPress 5.1.x < 5.1.10 Object injectionWeb Application ScanningComponent Vulnerability
critical
112786WordPress 5.0.x < 5.0.13 Object injectionWeb Application ScanningComponent Vulnerability
critical
112785WordPress 4.9.x < 4.9.18 Object injectionWeb Application ScanningComponent Vulnerability
critical
112784WordPress 4.8.x < 4.8.17 Object injectionWeb Application ScanningComponent Vulnerability
critical
112783WordPress 4.7.x < 4.7.21 Object injectionWeb Application ScanningComponent Vulnerability
critical
112782WordPress 4.6.x < 4.6.21 Object injectionWeb Application ScanningComponent Vulnerability
critical
112781WordPress 4.5.x < 4.5.24 Object injectionWeb Application ScanningComponent Vulnerability
critical
112780WordPress 4.4.x < 4.4.25 Object injectionWeb Application ScanningComponent Vulnerability
critical
112779WordPress 4.3.x < 4.3.26 Object injectionWeb Application ScanningComponent Vulnerability
critical
112778WordPress 4.2.x < 4.2.30 Object injectionWeb Application ScanningComponent Vulnerability
critical
112777WordPress 4.1.x < 4.1.33 Object injectionWeb Application ScanningComponent Vulnerability
critical
112776WordPress 4.0.x < 4.0.33 Object injectionWeb Application ScanningComponent Vulnerability
critical
112775WordPress 3.9.x < 3.9.34 Object injectionWeb Application ScanningComponent Vulnerability
critical
112774WordPress 3.8.x < 3.8.36 Object injectionWeb Application ScanningComponent Vulnerability
critical
112773WordPress 3.7.x < 3.7.36 Object injectionWeb Application ScanningComponent Vulnerability
critical
120921Fedora 28 : php-PHPMailer (2018-f73869d61e)NessusFedora Local Security Checks
high
120666Fedora 29 : php-PHPMailer (2018-a2e9bd6eae)NessusFedora Local Security Checks
high
120257Fedora 29 : php-phpmailer6 (2018-18f3eff32b)NessusFedora Local Security Checks
high
120237Fedora 28 : php-phpmailer6 (2018-0f5e6e9957)NessusFedora Local Security Checks
high
119508Debian DSA-4351-1 : libphp-phpmailer - security updateNessusDebian Local Security Checks
high
119159Fedora 27 : php-PHPMailer (2018-daee493feb)NessusFedora Local Security Checks
high
119155Fedora 27 : php-phpmailer6 (2018-46b92c9064)NessusFedora Local Security Checks
high
119119Debian DLA-1591-2 : libphp-phpmailer regression updateNessusDebian Local Security Checks
high
119109FreeBSD : phpmailer -- Multiple vulnerability (b036faba-edd8-11e8-b3b7-00e04c1ea73d)NessusFreeBSD Local Security Checks
high