CVE-2018-19107

MEDIUM

Description

In Exiv2 0.26, Exiv2::IptcParser::decode in iptc.cpp (called from psdimage.cpp in the PSD image reader) may suffer from a denial of service (heap-based buffer over-read) caused by an integer overflow via a crafted PSD image file.

References

https://access.redhat.com/errata/RHSA-2019:2101

https://github.com/Exiv2/exiv2/issues/427

https://github.com/Exiv2/exiv2/pull/518

https://lists.debian.org/debian-lts-announce/2019/02/msg00038.html

https://usn.ubuntu.com/4056-1/

Details

Source: MITRE

Published: 2018-11-08

Updated: 2020-08-24

Type: CWE-190

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM