CVE-2018-17183

MEDIUM

Description

Artifex Ghostscript before 9.25 allowed a user-writable error exception table, which could be used by remote attackers able to supply crafted PostScript to potentially overwrite or replace error handlers to inject code.

References

http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=fb713b3818b52d8a6cf62c951eba2e1795ff9624

https://access.redhat.com/errata/RHSA-2018:3834

https://bugs.ghostscript.com/show_bug.cgi?id=699708

https://lists.debian.org/debian-lts-announce/2018/09/msg00038.html

https://usn.ubuntu.com/3773-1/

Details

Source: MITRE

Published: 2018-09-19

Updated: 2019-03-11

Type: CWE-20

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH