CVE-2018-16868

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A Bleichenbacher type side-channel based padding oracle attack was found in the way gnutls handles verification of RSA decrypted PKCS#1 v1.5 data. An attacker who is able to run process on the same physical core as the victim process, could use this to extract plaintext or in some cases downgrade any TLS connections to a vulnerable server.

References

http://cat.eyalro.net/

http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00017.html

http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00068.html

http://www.securityfocus.com/bid/106080

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16868

Details

Source: MITRE

Published: 2018-12-03

Updated: 2020-12-04

Type: CWE-203

Risk Information

CVSS v2

Base Score: 3.3

Vector: AV:L/AC:M/Au:N/C:P/I:P/A:N

Impact Score: 4.9

Exploitability Score: 3.4

Severity: LOW

CVSS v3

Base Score: 5.6

Vector: CVSS:3.1/AV:P/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N

Impact Score: 4.7

Exploitability Score: 0.4

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:gnu:gnutls:*:*:*:*:*:*:*:* versions up to 3.6.4 (inclusive)

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
126442SUSE SLED15 / SLES15 Security Update : gnutls (SUSE-SU-2019:1351-2)NessusSuSE Local Security Checks
medium
125619openSUSE Security Update : gnutls (openSUSE-2019-1477)NessusSuSE Local Security Checks
medium
125465SUSE SLED15 / SLES15 Security Update : gnutls (SUSE-SU-2019:1351-1)NessusSuSE Local Security Checks
medium
124714openSUSE Security Update : gnutls (openSUSE-2019-1353)NessusSuSE Local Security Checks
medium
124454SUSE SLED15 / SLES15 Security Update : gnutls (SUSE-SU-2019:1121-1)NessusSuSE Local Security Checks
medium
121169Fedora 28 : gnutls (2019-1a0d4443f8)NessusFedora Local Security Checks
medium
121141Fedora 29 : gnutls (2019-99eefddc65)NessusFedora Local Security Checks
medium
121076Fedora 28 : gnutls (2019-24dc022a51)NessusFedora Local Security Checks
medium
120549Fedora 29 : gnutls (2018-79f7540a1e)NessusFedora Local Security Checks
medium
119447Slackware 14.2 / current : gnutls (SSA:2018-339-01)NessusSlackware Local Security Checks
medium