CVE-2018-12294

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

WebCore/platform/graphics/texmap/TextureMapperLayer.cpp in WebKit, as used in WebKitGTK+ prior to version 2.20.2, is vulnerable to a use after free for a WebCore::TextureMapperLayer object.

References

http://packetstormsecurity.com/files/148200/WebKitGTK-Data-Leak-Code-Execution.html

http://www.openwall.com/lists/oss-security/2018/06/14/1

http://www.securityfocus.com/archive/1/542087/100/0/threaded

https://bugs.webkit.org/show_bug.cgi?id=184729

https://security.gentoo.org/glsa/201808-04

https://trac.webkit.org/changeset/231300/webkit

Details

Source: MITRE

Published: 2018-06-19

Updated: 2018-10-21

Type: CWE-416

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:webkit:webkitgtk\+:*:*:*:*:*:*:*:*

Tenable Plugins

View all (1 total)

IDNameProductFamilySeverity
112078GLSA-201808-04 : WebkitGTK+: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high